Outlook için Microsoft Dynamics 365 Uygulaması kullanılırken Microsoft Dynamics 365 sunucu hatanıza bağlanılamıyor

Bu makalede, Microsoft Dynamics 365 sunucunuza bağlanamıyoruz hatası nedeniyle Outlook için Microsoft Dynamics 365 Uygulamasını kullanamamanıza neden olan sorun için bir çözüm sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics 365
Özgün KB numarası: 4341413

Belirtiler

Outlook için Microsoft Dynamics 365 Uygulamasını kullanmaya çalışırken aşağıdaki iletiyi alırsınız:

"Microsoft Dynamics 365 sunucunuza bağlanamazsınız. Lütfen uygulamayı kapatıp yeniden açmayı deneyin."

Daha fazla göster'i seçerseniz aşağıdaki iletiyi görebilirsiniz:

"İstemci yükleyicisi zaman aşımı"

Uygulamayı Outlook Web Access'te (OWA) kullanıyorsanız ekranın en altında aşağıdaki istemi görebilirsiniz:

"Bilgisayarınızda ek depolama alanı kullanılmasına izin dynamics.com vermek istiyor musunuz?"

Internet Explorer tarayıcı önbelleğini temizlerseniz, bu hata çözülmüş gibi görünebilir ancak sonunda döndürülür.

Neden

Microsoft, Internet Explorer önbelleğe alınabilecek veri miktarını sınırlandıracak şekilde yapılandırıldığından bu hatanın oluşabileceği bir sorunun farkındadır. Uygulamayı Internet Explorer kullanarak görüntülüyorsanız, hatanın nedeni bu olabilir. Outlook Masaüstü'nü kullanırken bu hatayla karşılaşırsanız, Outlook uygulamayı görüntülemek için her zaman Internet Explorer'ı kullanıyordur.

Çözüm

Microsoft, bu sorunu önlemek için bir değişiklik üzerinde çalışıyor. Bu arada, olası bir geçici çözüm olarak aşağıdaki adımları kullanabilirsiniz:

Seçenek 1 - Internet Explorer seçeneklerinde veritabanı sınırını artırma

İşletim sisteminizin sürümüne bağlı olarak, Internet Explorer ayarlarında sınırı değiştirebilirsiniz. Windows 10 kullanıyorsanız, bu seçenek görünmez ve bunun yerine Seçenek 2'yi kullanabilirsiniz.

  1. Internet Explorer'ı açın.
  2. Sağ üst köşede dişli simgesini ve ardından İnternet seçenekleri'ni seçin.
  3. Gözatma geçmişi bölümünün Genel sekmesinde Ayarlar'ı seçin.
  4. Önbellekler ve veritabanları sekmesini seçin.
  5. Web sitesi önbelleği veya veritabanı aşıldığında bana bildir seçeneğini görürseniz, değeri 200 olarak değiştirin ve Tamam'ı seçin. Alternatif olarak, web siteleri listesinden seçim dynamics.com yapabilir ve ardından Sınırı aş'ı seçebilirsiniz. Bu seçenekler görünmüyorsa Seçenek 2'ye geçin.
  6. Internet Explorer geçmişini ve önbelleğini temizleyin. Ayrıntılı adımlar için bkz. Internet Explorer'da gözatma geçmişinizi görüntüleme ve silme.

Seçenek 2 - Kayıt defteri içindeki veritabanı sınırını artırma

Önemli

Bu bölüm, kayıt defterini nasıl değiştirebileceğinizi gösteren adımlar içerir. Ancak kayıt defterini hatalı biçimde değiştirirseniz önemli sorunlar oluşabilir. Bu nedenle bu adımları dikkatle uyguladığınızdan emin olun. Ek koruma için kayıt defterini değiştirmeden önce yedeklemeyi unutmayın. Böylece, bir sorun oluşursa kayıt defterini daha sonra geri yükleyebilirsiniz. Kayıt defterini yedekleme ve geri yükleme hakkında daha fazla bilgi için bkz. Windows'ta kayıt defterini yedekleme ve geri yükleme.

İzin verilen önbelleğe alma sınırını artırmak için aşağıdaki kayıt defteri girdisini oluşturun:

Alt anahtar: HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\BrowserStorage\IndexedDBValue
Ad: MaxTrustedDomainLimitInMB
Tür: REG_DWORD
Veri: 200

Bu kayıt defteri girdisini oluşturmak için şu adımları izleyin:

  1. Başlat'ı seçin, Çalıştır'ı seçin, regedit yazın ve ardından TAMAM'ı seçin.

  2. Aşağıdaki kayıt defteri alt anahtarını bulun ve seçin. Bu konumun yolu yoksa, belirtilen anahtarları oluşturmanız gerekebilir:

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\BrowserStorage\IndexedDBValue

  3. IndexedDBValue'ya sağ tıklayın, Yeni'nin üzerine gelin ve DWORD Değeri'ni seçin.

  4. Yeni Değer #1 kutusuna MaxTrustedDomainLimitInMB yazın ve Enter tuşuna basın.

  5. MaxTrustedDomainLimitInMB öğesine sağ tıklayın ve değiştir'i seçin.

  6. Ondalık'ı seçin, 200 yazın ve tamam'ı seçin.

  7. Kayıt defteri Düzenleyici çıkın ve bilgisayarı yeniden başlatın.

  8. Internet Explorer geçmişini ve önbelleğini temizleyin. Ayrıntılı adımlar için bkz. Internet Explorer'da gözatma geçmişinizi görüntüleme ve silme.

Daha fazla bilgi

Bu hatanın birden çok olası nedeni vardır. Bu işlem sorunu çözmezse, ek olası çözümler için aşağıdaki makaleye bakın:

Outlook için Dynamics 365 Uygulaması kullanılırken "Microsoft Dynamics 365 sunucunuza bağlanılamıyor" hatası