Senaryo: Azure HDInsight'ta Apache Yarn günlüğü okunamıyor
Bu makalede, Azure HDInsight kümeleriyle etkileşim kurarken karşılaşılan sorunlara yönelik sorun giderme adımları ve olası çözümler açıklanmaktadır.
Sorun
Depolama hesabından bulunan Apache Yarn günlükleri insanlar tarafından okunamaz. Dosya ayrıştırıcısı çalışmıyor ve aşağıdaki hata iletisini üretir:
java.io.IOException: Not a valid BCFile.
Nedeni
Apache Yarn günlüğü, dosya ayrıştırıcısı tarafından desteklenmeyen biçimde toplanır IndexFile
.
Çözüm
Bir web tarayıcısından adresine gidin
https://CLUSTERNAME.azurehdinsight.net
; buradaCLUSTERNAME
kümenizin adıdır.Ambari kullanıcı arabiriminden YARN>Yapılandırmaları>Gelişmiş Gelişmiş>yarn-site'ye gidin.
WASB depolama için: için
yarn.log-aggregation.file-formats
varsayılan değerdirIndexedFormat,TFile
. değerini olarakTFile
değiştirin.ADLS depolama için: için
yarn.nodemanager.log-aggregation.compression-type
varsayılan değer şeklindedirgz
. değerini olaraknone
değiştirin.Değişikliği kaydedin ve etkilenen tüm hizmetleri yeniden başlatın.
Sonraki adımlar
Sorununuzu görmediyseniz veya sorununuzu çözemiyorsanız daha fazla destek için aşağıdaki kanallardan birini ziyaret edin:
Azure Topluluk Desteği aracılığıyla Azure uzmanlarından yanıt alın.
müşteri deneyimini geliştirmek için resmi Microsoft Azure hesabı olan @AzureSupport ile bağlantı kurun. Azure topluluğunun doğru kaynaklara bağlanması: yanıtlar, destek ve uzmanlar.
Daha fazla yardıma ihtiyacınız varsa Azure portal bir destek isteği gönderebilirsiniz. Menü çubuğundan Destek'i seçin veya Yardım + destek hub'ını açın. Daha ayrıntılı bilgi için bkz. Azure desteği isteği oluşturma. Abonelik Yönetimi ve faturalama desteğine erişim, Microsoft Azure aboneliğinize dahildir ve Teknik Destek, Azure Destek Planlarından biri aracılığıyla sağlanır.