Aracılığıyla paylaş


E-posta Yönlendiricisi İzinler nedeniyle Microsoft Dynamics'ten E-posta gönderemiyor

Bu makalede, E-posta Yönlendiricisi'nin izinler nedeniyle Microsoft Dynamics'ten E-posta gönderememesi sorununa yönelik bir çözüm sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics 365 Customer Engagement Online
Özgün KB numarası: 4494727

Belirtiler

Dynamics 365 örneğinden e-posta göndermek için Dynamics 365 E-posta Yönlendiricisi kullanılırken, e-posta Bekleyen Gönderme durumuna geçebilir ve hiçbir zaman göndermeyebilir:

E-postanın Bekleyen Gönderme durumunda olduğunu gösteren ekran görüntüsü.

Dynamics E-posta Yönlendiricisi özel durum günlükleri aşağıdaki hatayı gösterebilir:

İşlenmek üzere giden e-posta iletileri denetlenirken bir hata oluştu: https://disco.crm.dynamics.com/\<OrgName>. System.ServiceModel.FaultException'1[Microsoft.Xrm.Sdk.OrganizationServiceFault]: Kullanıcının farklı gönderme ayrıcalığı yok. (Hata Ayrıntısı, Özel durum ayrıntılarına eşittir:

ErrorCode: 0x8004480D
İleti: Kullanıcının farklı gönderme ayrıcalığı yok.

Neden

Bu davranış, Dynamics 365 uygulamasının önceki sürümlerinde bu izinlere gerek kalmadan işe yaramış olabilir. 8.2.2 ve 9.x sürümlerinin belirli yinelemelerinde güvenlik modeline yapılan değişiklikler nedeniyle, E-posta Yönlendiricisi'nin başka bir kullanıcıya e-posta gönderebilmesi için bu izinlerin açıkça verilmesi gerekir.

Çözüm

Bu e-postayı gönderen kullanıcı, diğer Dynamics kullanıcılarından kişisel seçeneklerinde e-posta gönderilmesine izin vermelidir:

Diğer Microsoft Dynamics 365 kullanıcılarının sizin yerinize e-posta göndermesine izin ver seçeneğini belirlemeye yönelik ekran görüntüsü.

E-posta Yönlendiricisi tarafından kullanılan hesabın Dynamics içinde E-postayı Başka Bir Kullanıcı Olarak Gönder izni de olmalıdır:

E-postayı Başka Bir Kullanıcı Olarak Gönder izninin ekran görüntüsü.

Daha Fazla Bilgi