Not
Bu sayfaya erişim yetkilendirme gerektiriyor. Oturum açmayı veya dizinleri değiştirmeyi deneyebilirsiniz.
Bu sayfaya erişim yetkilendirme gerektiriyor. Dizinleri değiştirmeyi deneyebilirsiniz.
Bu makale, Güncelleştirme Paketi 12'yi Microsoft Dynamics CRM 2011 Server Güncelleştirme Paketi 11'e uyguladıktan sonra herhangi bir web sayfasına erişememe sorununu düzeltmenize yardımcı olur.
Şunlar için geçerlidir: Microsoft Dynamics CRM 2011
Özgün KB numarası: 2906374
Belirtiler
Güncelleştirme Paketi 11 Dynamics CRM Server'ın üzerine Güncelleştirme Paketi 12 uygulandıktan sonra herhangi bir Microsoft Dynamics CRM 2011 web sayfasına erişmeye çalışırken bir hata oluşur:
>Crm İstisnası: Mesaj: Genel SQL hatası. Hata Kodu: -2147204784, InnerException: System.Data.SqlClient.SqlException (0x80131904): 'ObjectTypeCodeName' isimli sütun geçersiz.
Geçersiz 'ObjectTypeCodeName' sütun adı.
Neden
Bu sorun, yalnızca aşağıdaki iki diziden biri sağlandığında ortaya çıkar:
- Güncelleştirme Paketi 12, Güncelleştirme Paketi 10'un altındaki bir CRM Server sürümünün üzerine uygulanır.
- Ardından CRM Sunucusu Güncelleştirme Paketi 11'e geri alınır.
- Güncelleştirme Paketi 12 daha sonra Güncelleştirme Paketi 11'in üzerine uygulanır.
veya
- Güncelleştirme Paketi 7'nin üzerine Güncelleştirme Paketi 12 uygulanır.
- CRM Sunucusu Güncelleştirme Paketi 7 sürümüne geri alınır.
- Güncelleştirme Paketi 11'in uygulanmasına yönelik bir deneme yapıldı; ancak dosya sürümleri doğru sürüm numarasına değişmedi.
- Güncelleştirme Paketi 15 uygulanır.
Çözüm
Bu sorunu çözmek için veritabanı güncelleştirmelerinin yapılması gerekir. Bunu yapmadan önce SQL Server'da CRM veritabanlarınızın tam yedeğine sahip olduğunuzdan emin olmanız gerekir.
Tam Veritabanı Yedeklemesi Oluşturma
Bu işlem tamamlandıktan sonra SQL Server Management Studio'da aşağıdaki iki komutu çalıştırın:
delete from MetadataSchema.Attribute where AttributeId in ('4456bbb5-0bad-4360-afca-74d099056116', 'c3dce60b-fd95-43b4-8d20-ea4bbcd5c436');
delete from AttributeIds where AttributeId in ('4456bbb5-0bad-4360-afca-74d099056116', 'c3dce60b-fd95-43b4-8d20-ea4bbcd5c436');
Bu alanları kaldırdıktan sonra bir IISReset işlemini tamamlamanız gerekir.