Microsoft Dynamics 365'e güncelleştirdikten sonra, kaynak ve hedef kuruluşlar arasında eşleşmeyen İş Süreci Akışı varlık adları Çözüm İçeri Aktarma hatasına neden olabilir
Bu makalede, Microsoft Dynamics 365 güncelleştirildikten sonra oluşan bir hataya çözüm sağlanır.
Şunlar için geçerlidir: Microsoft Dynamics CRM
Özgün KB numarası: 4020021
Belirtiler
İş Süreci Akışları içeren yönetilmeyen bir Çözümün dağıtıldığı bir kuruluştan yönetilen Çözüm oluşturduktan sonra çözümü başka bir kuruluşa aktarın. Çözüm içeri aktarıldıktan sonra hem kaynak hem de hedef kuruluşlar Dynamics 365 olarak güncelleştirilir. Ardından, aynı kaynaktan başka bir Çözüm (örneğin, özgün çözümün güncelleştirilmiş bir sürümü) oluşturulur ve aynı İş Süreci Akışları ve ilgili İş Süreci Akışı varlıklarıyla içeri aktarılırsa aşağıdaki hata oluşur:
"Bu işlem güncelleştirilemediği veya benzersiz bir ada sahip olmadığı için içeri aktarılamıyor."
Neden
Dynamics 365 yükseltirken İş Süreci Akışları (BPF), İş Süreci Akışı varlıklarıyla temsil edilir. Bu varlıklar yükseltme sırasında oluşturulur ve aşağıdaki biçim kullanılarak adlandırılır:
<SolutionPrefix>_BPF_<ProcessId>
Özgün kuruluştan oluşturulan Yönetilen Çözümdeki İş Süreci Akışı varlıkları, ikinci kuruluştaki varlıklardan farklı şekilde adlandırıldığından. Dynamics 365 yükseltildikten sonra, aynı İş Süreci Akışları için İş Süreci Akışı varlık adlarındaki çakışma nedeniyle çözümlerin ikinci kuruluşa aktarılması başarısız olur.
Çözüm
Çözümlerin oluşturulduğu ve dışarı aktarıldığı kaynak (yönetilmeyen) kuruluşta aşağıdaki adımları izleyin.
İş Süreci Akışlarını yönetilmeyen çözüm olarak içeren mevcut çözümü 8.1 veya 8.0 olarak dışarı aktarın. Dışarı aktarılan Çözümün destekleyen İş Süreci Akışı varlıklarını içermediğinden emin olmak için yapılır.
İş Süreci Akışlarını (ilgili İş Süreci Akışı varlıklarını ve bu varlıklardaki verileri de siler) ve yönetilmeyen Çözümü kaynak sistemden devre dışı bırakır (etkinse) ve siler.
Yeni dışarı aktarılan, yönetilmeyen Çözümü güncelleştirin.
- uygun müşteri Çözüm Yayımcısı ön ekini kullanmak için customizations.xml her bir İş Akışı düğümünün UniqueName düğümünü yeniden adlandırın. Bu Çözüm kaynak (yönetilmeyen) ortama geri aktarıldığında, oluşturulan İş Süreci Akışı varlıklarının sorunun kök nedeni olan adlandırma çakışmasını gidermek için İş Süreci Akışlarının zaten mevcut olduğu hedef kuruluşlarda bulunan varlıklarla aynı ada sahip olmasını sağlamak için yapılır.
- Varsa, solution.xml dosyasındaki MissingDependencies üst düğümünden eski
new_bpf_<processid>
adlandırılmış varlıklar için eksik bağımlılık girdilerini (tüm MissingDependency düğümleri ) kaldırın. MissingDependencies üst düğümünü arkasında ve sonrasında boş bıraktığından emin olun. Bu, gelecekte giderilecek bilinen bir sorundur. Eksik bağımlılıklar silindikten sonra şöyle görünmelidir: <MissingDependencies></MissingDependencies> - solution.xml ImportExportXml kök öğesinin başındaki sürüm düğümünü, yukarıdaki 1. Adımda Farklı Dışarı Aktar işlemini yaptığınız sürüme bağlı olarak 8.1 veya 8.0 olarak güncelleştirin. İkincil sürüm numaralarını olduğu gibi bırakabilirsiniz. Burada gördüğünüz sürümün Farklı Dışarı Aktardığınız sürümle tutarlı olduğundan emin olmak için bu güncelleştirme gereklidir. Başvuru için (8.1 için), ImportExportXml version= "8.1.0000.0788" ve ardından etiket özniteliklerinin geri kalanı gibi <görünür.
Değiştirilen, yönetilmeyen Çözümü kaynak (yönetilmeyen) ortama geri aktarın.
4. adım, İş Süreci Akışlarının (aynı tanım ve kimlikler) ve ilişkili, doğru adlandırılmış İş Süreci Akışı varlıklarının doğru şekilde oluşturulmasına neden olur. Ayarlar, Özelleştirmeler, Sistemi Özelleştir'i seçerek ve İş Süreci Akışı varlıklarının adları doğrulanarak doğrulanabilir. Artık uygun çözüm ön ekini kullanıyor olmaları gerekir.
Şimdi bu Çözümü yönetilen olarak dışarı aktarın ve hedef kuruluşlarınıza içeri aktarmayı deneyin. Artık Dynamics 365 yükseltmeden önce yönetilen bir çözüm aracılığıyla sunulan bu İş Süreci Akışlarını içeren hedef kuruluşa başarıyla aktarılmalıdır.