İngilizce dilinde oku

Aracılığıyla paylaş


Sanal makinelerde "FSLogix_unsupported_environment" ve OneDrive eşitleme hatası

Belirtiler

FSLogix kullanılarak yapılandırılan sanal makinelerde, OneDrive eşitleme istemcisi eşitlenemez ve aşağıdaki hata iletilerini alırsınız:

OneDrive eşitleyemiyor
Yardım için sistem yöneticinize başvurun.
Hata kodu: FSLogix_unsupported_environment

Ayrıca, hata iletisi penceresini kapattıktan sonra OneDrive eşitleme istemcisi kapanır.

Neden

Bu sorun, OneDrive eşitleme istemcisinin FSLogix 2009 düzeltme 1'den önceki FSLogix sürümlerini kullanan sanal makinelerde engellenmesi nedeniyle oluşur. Bu önceki sürümler artık Microsoft tarafından desteklenmiyor.

Çözüm

Sorunu çözmek için, OneDrive eşitleme istemcisini kullanan tüm sanal makinelere FSLogix'in en son sürümünü indirin ve yükleyin.

Daha fazla bilgi

Yöneticiler, ortamlarında çalışan sanal makinelerde FSLogix sürümünü denetlemek için aşağıdaki yöntemlerden birini kullanabilir.

Birden çok sanal makinede FSLogix sürümünü denetleme

Not: Aşağıdaki PowerShell betiği olduğu gibi sağlanır ve Microsoft tarafından desteklenmez.

FSLogix Sürüm Doğrulama betiğini kullanın.

Bir sanal makinede FSLogix sürümünü denetleme

  • FSLogix FRX komut satırı aracını kullanın:

    Console
    C:\Program Files\FSLogix\Apps\frx.exe version
    
  • FSLogix kayıt defteri anahtarının InstallVersion özelliğini almak için aşağıdaki PowerShell komutunu çalıştırın:

    PowerShell
    (Get-ItemProperty -Path HKLM:\SOFTWARE\FSLogix\Apps).InstallVersion
    
  • Sistemde yüklü olan Microsoft FSLogix Uygulamalarının sürümünü almak için aşağıdaki PowerShell komutlarını çalıştırın:

    PowerShell
    $uninstallPath = "HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall"
    $appCheck = Get-ItemProperty -Path $uninstallPath\* | Where-Object { $_.DisplayName -eq "Microsoft FSLogix Apps" }
    ($appCheck | Where-Object {$_.EstimatedSize -eq ($appCheck | Measure-Object -Maximum EstimatedSize).Maximum}).DisplayVersion