Not
Bu sayfaya erişim yetkilendirme gerektiriyor. Oturum açmayı veya dizinleri değiştirmeyi deneyebilirsiniz.
Bu sayfaya erişim yetkilendirme gerektiriyor. Dizinleri değiştirmeyi deneyebilirsiniz.
Bu makalede, Bir Azure Kubernetes Service (AKS) kümesi oluşturmaya çalıştığınızda oluşan "AvailabilityZoneNotSupported" hatasını tanımlama ve çözme adımları anlatılmaktadır.
Önkoşullar
Azure CLI'ya erişim.
Belirti -leri
Aks kümesi oluşturma işlemi belirtilen kullanılabilirlik alanlarında başarısız olur ve aşağıdaki iletiyi içeren bir "AvailabilityZoneNotSupported" hatası alırsınız:
Kaynak grubu <kaynak-grubu-adı> içindeki kapsayıcı hizmeti <kaynak adı> için ön uçuş doğrulama kontrolü başarısız oldu. İleti: '<1' bölgesi 'agentpoolName>' kaynağı için desteklenmiyor. '<Konum>' konumu için desteklenen bölgeler :'A', 'B'
Nedeni
Sorun, istenen SKU'nun aboneliğinizin bazı ya da tüm bölgelerinde kısıtlamalara sahip olması nedeniyle kaynaklanır. Kısıtlamaları doğrulamak için SKU kısıtlamalarını doğrulama bölümüne gidin.
Çözüm
Bu sorunu çözmek için Azure bölgesi erişim isteği işlemini izleyerek belirtilen bölgeye veya bölgeye erişim isteyin.
SKU kısıtlamalarını doğrulama
Aşağıdaki komutlardan birini çalıştırarak SKU ayrıntılarını listeleyin:
az vm list-skus -l <location> --size <SKU>az rest --method get \ --url "https://management.azure.com/subscriptions/<subscription>/providers/Microsoft.Compute/skus?%24filter=location+eq+%27<location>%27&api-version=2022-03-01" >> availableSkus.txtUyarı
<subscription>,<SKU>ve<location>değerlerini buna göre değiştirin.komut çıktısından istenen SKU'yu arayın.
Aşağıdaki gibi bilgiler görürseniz, istenen SKU'nun aboneliğinizin bazı bölgelerinde veya tüm bölgelerinde kısıtlamaları olduğunu gösterir:
"restrictions": [ { "type": "Zone", "values": [ "<zone>" ], "restrictionInfo": { "locations": [ "<location>" ], "zones": [ "1", "2", "3" ] }, "reasonCode": "NotAvailableForSubscription" } ]