Aracılığıyla paylaş


Randevular, kişiler ve görevler eşitlenirken iç Microsoft Dynamics 365 hatası oluştu

Bu makalede, Dynamics 365'daki bir posta kutusu kaydında Posta Kutusunu Etkinleştir & Test Et'i seçtikten sonra oluşan bir hataya çözüm sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics 365
Özgün KB numarası: 4346733

Belirtiler

Dynamics 365'da posta kutusu kaydında Posta Kutusunu Etkinleştir & Test Et'i seçtikten sonra, Randevular, Kişiler ve Görevler test sonucu Hata olarak gösterilir ve Uyarılar bölümünde aşağıdaki ileti görüntülenir:

"[Posta Kutusu Adı] posta kutusu için randevular, kişiler ve görevler eşitlenirken bir iç Microsoft Dynamics 365 hatası oluştu. Posta kutusu eşitlenmedi. İlişkili e-posta sunucusu profilinin sahibine [Email Sunucu Profili Adı] bildirilmiştir.
Email Sunucusu Hata Kodu: UserPrivilegeError"

Neden

Bu hata iletisini görürseniz ve Email Sunucu Hata Kodu UserPrivilegeError olarak gösterilir ve bu, bu posta kutusunun sahibi olan kullanıcının yeterli ayrıcalığına sahip olmadığını gösterir. Gerekli ayrıcalıkların listesi için Server-Side Eşitleme kullanılırken PrivilegeDenied hatası oluşuyor bölümüne bakın.

Önemli

Posta kutusu kaydının Sahibi'nin Kullanıcı ile aynı olduğunu doğrulayın. Örnek: Posta kutusu Paul Cannon için bir Kullanıcı posta kutusuysa, Paul Cannon için posta kutusu kaydındaki Sahip değerinin Paul Cannon olarak gösterildiğini doğrulayın. Başka bir kullanıcıysa, bu kullanıcının posta kutusuna erişimi olmayabilir.

Çözüm

Bu sorunu gidermek için aşağıdaki adımları izleyin:

  1. Sistem Yöneticisi rolüne sahip bir kullanıcı olarak posta kutusu kaydını Dynamics 365 açın.

    Not

    Uyarı, posta kutusu kaydına bir bağlantı içerir.

  2. Posta kutusu formundaki Sahip alanının Kullanıcı adıyla doldurulup doldurulmadığını doğrulayın. Başka bir kullanıcı listeleniyorsa, bu kullanıcıyla aynı olacak şekilde değiştirin.
  3. Sahip alanındaki bağlantıyı seçerek sahip olan kullanıcının Kullanıcı kaydını açın.
  4. Bu kullanıcıya hangi güvenlik rollerinin atandığı görmek için Rolleri Yönet'i seçin.
  5. Ayarlar'a gidin, Güvenlik'i ve ardından Güvenlik Rolleri'ne tıklayın.
  6. 4. adımda bulunan rolleri açın. Gerekli ayrıcalıkların listesi için Server-Side Eşitleme kullanılırken PrivilegeDenied hatası oluşuyor bölümüne bakın ve kullanıcının güvenlik rolünün bu ayrıcalıkları içerdiğini doğrulayın.
  7. Kullanıcının posta kutusu kaydının sahibi olduğunu ve güvenlik rolünün gerekli ayrıcalıkları içerdiğini doğruladıktan sonra, posta kutusu kaydındaki Test & Posta Kutusunu Etkinleştir düğmesini yeniden seçin. Test Başarılı sonucunu vermezse Uyarılar bölümünde görüntülenen iletiyi gözden geçirin.