Aracılığıyla paylaş


Microsoft Dynamics 365'de geçersiz XML hatası oluştuğundan bu çözüm paketi içeri aktarılamıyor

Bu makalede, Microsoft Dynamics 365'de bir çözümü içeri aktarmaya çalıştığınızda oluşan bir hataya çözüm sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics 365
Özgün KB numarası: 4456502

Belirtiler

Dynamics 365'da bir çözümü içeri aktarmaya çalışırken aşağıdaki hatayı alırsınız:

"Bu çözüm paketi geçersiz XML içerdiği için içeri aktarılamıyor. Şema doğrulama hatalarında bulunan bilgileri kullanarak XML içeriğini el ile düzenleyerek dosyayı onarmayı veya çözüm sağlayıcınıza başvurabilirsiniz.
Hata kodu 8004801a."

Teknik Ayrıntılar'ı seçerseniz, diğer hata ayrıntılarıyla birlikte aşağıdaki iletiyi görürsünüz:

"Sıkıştırılmış çözüm paketi dosyasındaki customizations.xml dosyasının şema doğrulaması başarısız oldu. Dosyayı el ile doğrulamak ve düzenlemek için şema dosyasını buradan indirebilir ve daha fazla ayrıntı almak için şema doğrulamayı destekleyen bir XML düzenleyicisi kullanabilirsiniz."

Neden

Çözüm paketi, XML olarak depolanan Dynamics 365 özelleştirmeleri içerir. Bu XML, hangi öğelerin geçerli olduğunu tanımlayan belirli bir şema tanımına sahiptir. XML şema tanımına göre geçerli olmayan öğeler içeriyorsa, çözümü içeri aktarmaya çalışırken bu hata iletisi görüntülenir.

Çözüm

Ayrıntıların bilinen bir sorunla eşleşip eşleşmediğini denetleyin
Teknik Ayrıntıları görüntüleme seçeneğini belirleyin ve aşağıdaki bilinen sorunlardan herhangi biri ile eşleşip eşleşmediğini görün:

Özelleştirmeler XML'sini el ile değiştirdiyseniz
Hata iletişim kutusundaki Teknik Ayrıntılar bağlantısını seçin. Ardından XML'de hangi geçersiz öğelerin bulunduğu hakkında ek ayrıntılar görürsünüz. İleti ayrıca şema doğrulamayı destekleyen bir XML düzenleyicisiyle kullanılabilecek şema dosyasını indirmek için bir bağlantı içerir. XML'deki geçersiz öğeleri düzeltdikten sonra çözümü içeri aktarmayı yeniden deneyin.

Daha fazla bilgi için bkz. Özelleştirmeler XML dosyasını şema doğrulamasıyla düzenleme

Çözümü bir çözüm sağlayıcısından aldıysanız
Çözüm sağlayıcınıza başvurun.