Aracılığıyla paylaş


Outlook'ta ikincil posta kutusunda klasörlerle çalışırken karşılaşılan performans ve eşitleme sorunları

Özgün KB numarası: 3115602

Belirti -leri

Microsoft Outlook profilinize eklenmiş ikincil bir Microsoft Exchange Server posta kutusunda klasörlere erişmeye çalıştığınızda, rastgele performans sorunlarıyla karşılaşabilirsiniz. Örneğin, aşağıdaki belirtilerle karşılaşabilirsiniz:

  • İkincil posta kutusunda öğeleri görüntülediğinizde, yeni öğeler görünmeyebilir veya öğeler eksik gibi görünebilir.

  • Sildiğiniz öğeler ikincil posta kutusunda görünmeye devam ediyor.

  • Yavaş Outlook performansı veya rastgele donmalar.

  • Microsoft Exchange Server çalıştıran bir sunucuda, Uygulama günlüğüne aşağıdakine benzer bir olay günlüğe kaydedilir:

    Event Type: Error
    Event Source: MSExchangeIS
    Event Category: General
    Event ID: 9646
    Description:
    Closing Mapi session "/o=Organization/ou=Administrative Group/cn=Recipients/cn=recipient" because it exceeded the maximum of 500 objects of type "objtFolder".
    

Ayrıca, Outlook Eşitleme Sorunları klasöründeki eşitleme günlüğü iletilerinde aşağıdakine benzer hatalar bulabilirsiniz:

13:22:28 Synchronizer Version 12.0.6529 
13:22:28 Synchronizing Mailbox 'TeamShared' 
13:22:28 Synchronizing Hierarchy 
13:22:28 Error Synchronizing Hierarchy for Mailbox 'TeamShared' 
13:22:28 [80040305-54A-4DE-1900] 
13:22:28 Your server administrator has limited the number of items you can open simultaneously. Try closing messages you have opened or removing attachments and images from unsent messages you are composing. 
13:22:28 Microsoft Exchange Information Store 
13:22:28 For more information on this failure, click the URL below: 
13:22:28 http://www.microsoft.com/support/prodredirect/outlook2000_us.asp?err=80040305-54a-4de-1900 
13:22:28 Error synchronizing folder 

13:22:31 Synchronizing local changes in folder 'TeamShared - Level1' 
13:22:31 Error synchronizing folder 
13:22:31 [80040305-54A-4DE-421] 
13:22:31 Your server administrator has limited the number of items you can open simultaneously. Try closing messages you have opened or removing attachments and images from unsent messages you are composing. 
13:22:31 Microsoft Exchange Information Store 
13:22:31 For more information on this failure, click the URL below: 
13:22:31 http://www.microsoft.com/support/prodredirect/outlook2000_us.asp?err=80040305-54a-4de-421 When this issue occurred, the following synchronization error numbers have also been seen in synchronization messages in the Sync Issues folder:80040305-54A-4DE-822
80004005-501-0-1380 

Uyarı

Posta kutunuzda Eşitleme Sorunları klasörünü görmek için Gezinti bölmesinde Klasör Listesi modülünü seçmeniz gerekir.

Nedeni

Aşağıdaki koşullar doğruysa bu sorun oluşabilir:

  • Erişmeye çalıştığınız ikincil posta kutusu, Gezinti bölmesinde görünmesi için Outlook profilinize eklenir.

    Uyarı

    Microsoft Exchange iletişim kutusundaki Gelişmiş sekmesinden veya Exchange'deki "Otomatik Eşleme" özelliğini kullanarak profilinize el ile ikincil posta kutuları ekleyebilirsiniz.

    İkincil posta kutularını gösteren ekran görüntüsü.

  • Bu ikincil posta kutusu birçok klasör içerir.

  • Profiliniz Önbelleğe Alınmış Exchange Modu'nda yapılandırıldı.

  • Profilinizde Paylaşılan klasörleri indir varsayılan seçeneği etkindir.

    Paylaşılan klasörleri indir için varsayılan seçenekleri gösteren ekran görüntüsü.

Bu sorun, Outlook 2010 ve sonraki sürümlerinin ikincil posta kutusunda erişiminiz olan tüm klasörleri yerel olarak önbelleğe almasıyla (Outlook veri dosyanızda [.ost]) oluşur. Bu, Outlook'un önceki sürümlerinde yapılan bir değişikliktir. Outlook 2003 hiçbir paylaşılan klasörü önbelleğe almaz. Varsayılan olarak, Outlook 2007 yalnızca e-posta içermeyen paylaşılan klasörleri (Takvim, Kişiler ve Görevler gibi) önbelleğe alır.

Uyarı

Outlook 2007'de, Outlook istemcinizde aşağıdaki kayıt defteri verileri de yapılandırılmışsa bu sorun daha olasıdır.

Alt anahtar:

HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Cached Mode

Veya

HKEY_CURRENT_USER\Software\Policies \Microsoft\Office\12.0\Outlook\Cached Mode

DWORD: CacheOthersMail

Değer: 1

Çözüm

Office 365 için Outlook

Outlook'ta 500 paylaşılan klasör sınırlamasını kaldırma

Paylaşılan klasörlerin eşitlenmesi, Outlook'un artık 500 paylaşılan klasör sınırlaması ile karşılaşmaması ve Outlook'un en fazla 5.000 paylaşılan klasör barındırabilmesi için geliştirilmiştir. Yeni işlev sınırı, Outlook'un kullanılabilir kaynaklarına ve sistem yapılandırmasına göre değişir. Bu değişiklikler, sürüm 1904 sürümüyle Office Aylık (Hedefli) kanalında , sürüm 1905 (Derleme 11629.20196) ve sonraki sürümlerle Office Aylık Kanalı'na yayımlandı. Ayrıca Semi-Annual kanal yayınlarına normal Semi-Annual zamanlaması (Semi-Annual Kanalı için Eylül 2019 (Hedefli) ve genel sürüm için Ocak 2020) dahil edilir. Daha fazla bilgi için bkz. Outlook'ta 500 Klasör Sınırını Kaldırma.

Outlook 2019, Outlook 2016, Outlook 2013, Outlook 2010 ve Outlook 2007 için

Bu sorunu çözmek için aşağıdaki yöntemlerden birini kullanın.

Önemli

Bu bölüm, yöntem veya görev, kayıt defterini nasıl değiştirebileceğinizi gösteren adımlar içerir. Ancak, kayıt defterini yanlış bir şekilde değiştirirseniz ciddi sorunlar ortaya çıkabilir. Bu nedenle, bu adımları dikkatli bir şekilde izlediğinizden emin olun. Koruma amacıyla, bir sorun oluştuğunda kayıt defterini geri yükleyebilmek için kayıt defterini değiştirmeden önce yedekleyin. Kayıt defterini yedekleme ve geri yükleme hakkında daha fazla bilgi için bkz. Windows'ta kayıt defterini yedekleme ve geri yükleme.

Yöntem 1: Paylaşılan posta kutusunda klasör sayısını azaltma

Bu sorunun en iyi çözümü, özellikle posta kutularınız Office 365 ortamındaysa paylaşılan posta kutusunda posta klasörlerinin sayısını azaltmaktır. Bu makaledeki diğer 2 ve 3 yöntemleri, posta klasörlerinin veya paylaşılan posta kutusundaki tüm klasörlerin önbelleğe alınmasını kapatmanızı önerir. Bu çözümler işe yarasa da yavaş bir ağda Office 365 posta kutuları ve posta kutuları için önbelleğe alma özelliğinin etkin tutulması önerilir. Daha fazla bilgi için aşağıdaki makaleyi inceleyin:

Yavaş bir ağda Office 365'i kullanmak için en iyi yöntemler

Yöntem 2: Tüm paylaşılan klasörlerin önbelleğe alınmasını devre dışı bırakma

Outlook 2010 ve sonraki sürümleri

Outlook 2010 ve sonraki sürümlerde tüm paylaşılan klasörlerin önbelleğe alınmasını devre dışı bırakmak için şu adımları izleyin:

  1. Dosya sekmesinde, Hesap Ayarları listesinde Hesap Ayarları'nı seçin.

  2. Hesap Ayarları iletişim kutusunda E-posta sekmesini seçin ve ardından Microsoft Exchange Server hesabınıza çift tıklayın.

  3. Hesabı Değiştir iletişim kutusunda Diğer Ayarlar'ı seçin.

  4. Microsoft Exchange iletişim kutusunda Gelişmiş sekmesini seçin.

  5. Paylaşılan klasörleri indir onay kutusunu temizlemek için seçin.

    Paylaşılan klasörleri indir seçeneğini gösteren ekran görüntüsü.

  6. İki kez Tamam'ı seçin.

  7. İleri'yi, Son'u ve ardından Kapat'ı seçin.

  8. Outlook'u yeniden başlatın.

Outlook 2007

Outlook 2007'de tüm paylaşılan klasörlerin önbelleğe alınmasını devre dışı bırakmak için şu adımları izleyin:

  1. Araçlar menüsünde Hesap Ayarları'nı seçin.

  2. Hesap Ayarları iletişim kutusunda E-posta sekmesini seçin ve ardından Microsoft Exchange Server hesabınıza çift tıklayın.

  3. Hesabı Değiştir iletişim kutusunda Diğer Ayarlar'ı seçin.

  4. Microsoft Exchange iletişim kutusunda Gelişmiş sekmesini seçin.

  5. Paylaşılan klasörleri indir onay kutusunu temizlemek için seçin.

    Paylaşılan klasörleri indir seçeneğini gösteren ekran görüntüsü.

  6. İki kez Tamam'ı seçin.

  7. İleri'yi, Son'u ve ardından Kapat'ı seçin.

  8. Outlook'u yeniden başlatın.

Bu değişikliği yaptıktan sonra, çevrimdışı çalışırken ikincil posta kutusunda paylaşılan klasörlerin hiçbiri Outlook'ta kullanılamaz. Ancak, çevrimdışı çalışırken birincil posta kutusunda yer alan tüm klasörler kullanılabilir olmaya devam eder.

Grup İlkesi ayarını kullanarak paylaşılan klasörleri indirmeyi devre dışı bırakma hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleye gitmek için aşağıdaki makale numarasını seçin:

982697 Varsayılan olarak, paylaşılan posta klasörleri Outlook 2010 ve Outlook 2013'te Önbelleğe Alınmış modda indirilir

Yöntem 3: İkincil Exchange posta kutusunun yapılandırmasını profilinizdeki ikinci bir Exchange hesabıyla değiştirin

Yalnızca Outlook 2010 ve sonraki sürümleri

İkincil Exchange posta kutusunda tüm klasörleri önbelleğe almak istiyorsanız, outlook profilinizi değiştirerek ikincil posta kutusunun ikinci bir Exchange hesabı olarak eklenmesini sağlamak için bu adımları izleyin.

Uyarı

Bu adımları izlemek için, ikincil posta kutusunun hesabının parolasını bilmeniz veya ikincil posta kutusunun hesabında tam posta kutusu izinlerine sahip olmanız gerekir. Bu bilgi veya izinler için Exchange Server yöneticinize başvurun.

  1. İkincil posta kutusu için otomatik eşlemenin devre dışı olduğundan emin olun. Daha fazla bilgi için aşağıdaki Microsoft Bilgi Bankası makalesine bakın:

    2646504 Office 365'te paylaşılan posta kutusu için otomatik eşlemeyi kaldırma

  2. Dosya sekmesinde, Hesap Ayarları listesinde Hesap Ayarları'nı seçin.

  3. Hesap Ayarları iletişim kutusunda, E-posta sekmesini seçin ve ardından Microsoft Exchange Server hesabınıza çift tıklayın.

  4. Hesabı Değiştir iletişim kutusunda Diğer Ayarlar'ı seçin.

  5. Microsoft Exchange iletişim kutusunda Gelişmiş sekmesini seçin.

  6. Gelişmiş sekmesini seçin. Posta Kutuları bölümünde ikincil posta kutusunu ve ardından Kaldır'ı seçin.

  7. Posta kutusunun kaldırılmasını onaylamanız istendiğinde Evet'i seçin.

  8. Tamam'ı, İleri'yi, Son'u ve ardından Kapat'ı seçin.

    Uyarı

    Bu noktada, ikincil Exchange posta kutusu artık Outlook profilinizle ilişkilendirilmemiştir.

  9. Outlook'dan çıkın.

  10. Denetim Masası'nda Posta öğesini açın.

  11. Profilinizi ve ardından Özellikler'i seçin.

  12. E-posta Hesapları'nı seçin.

  13. Hesap Ayarları iletişim kutusunun E-posta sekmesinde Yeni'yi seçin.

  14. Yeni Hesap Ekle iletişim kutusunun Hizmet Seç bölümünde E-posta Hesabı'nı ve ardından İleri'yi seçin.

    İkincil posta kutusu hesabının parolasını biliyorsanız 14. adıma gidin.

    İkincil posta kutusu hesabının parolasını bilmiyorsanız ancak hesabınızın bu ikincil posta kutusu için tam posta kutusu izinleri varsa 18. adıma gidin.

  15. Yeni Hesap Ekle iletişim kutusunun Otomatik Hesap Kurulumu bölümünde, ikincil posta kutusu için aşağıdaki hesap bilgilerini girin ve İleri'yi seçin.

    • İsim
    • E-posta adresi
    • Şifre

    Otomatik Hesap Kurulumu bölümünü gösteren ekran görüntüsü.

  16. Hesap başarıyla yapılandırıldıktan sonra Son'u seçin.

  17. Kapat'ı, Kapat'ı ve ardından Tamam'ı seçin.

  18. 22. adıma gidin.

  19. Yeni Hesap Ekle iletişim kutusunun Otomatik Hesap Kurulumu bölümünde Sunucu ayarlarını veya ek sunucu türlerini el ile yapılandır'ı ve ardından İleri'yi seçin.

  20. Yeni Hesap Ekle iletişim kutusunun Hizmet Seç bölümünde Microsoft Exchange veya uyumlu hizmet'i ve ardından İleri'yi seçin.

  21. Yeni Hesap Ekle iletişim kutusunun Sunucu Ayarları bölümünde, ikincil posta kutusu için aşağıdaki bilgileri girin ve İleri'yi seçin.

    • Sunucu (Bu, Exchange sunucusu adıdır)
    • Önbelleğe Alınmış Exchange Modu'nu kullanın (ikincil posta kutusunun .ost dosyanızda yerel olarak önbelleğe alınmasına izin vermek için etkinleştirilir)
    • Kullanıcı adı

    Sunucu Ayarları bölümünü gösteren ekran görüntüsü.

  22. Son'u seçin, Kapat'ı seçin, Kapat'ı ve ardından Tamam'ı seçin.

  23. Outlook'u başlatın.

Uyarı

Hesabınızda ikincil posta kutusu için tam posta kutusu izinleri yoksa, ikincil posta kutusunun hesap kimlik bilgileri istenir. Bu yöntemde belirtilen yapılandırma değişikliklerini yaptıktan sonra Outlook'u kullanırken aşağıdaki özel sorunlarla karşılaşabilirsiniz.

  • Her iki Exchange posta kutusu için de yeni e-posta uyarıları görüntülenir.

Yeni e-posta uyarılarını gösteren ekran görüntüsü.

  • özel olarak işaretlenmiş iletiler, ilk Exchange posta kutusunun hesabı özel iletilerin görüntülenmesine izin verecek şekilde özel olarak yapılandırılmamış olsa bile ikinci Exchange posta kutusunda görüntülenebilir.

Özel ileti örneğini gösteren ekran görüntüsü.

Daha Fazla Bilgi

Outlook profilinize başka posta kutuları eklediğinizde ve paylaşılan posta kutusu klasörlerinin önbelleğe alınmasını etkinleştirdiğinizde, Outlook önbelleğe alınan her posta kutusuna her klasörü ayrı ayrı kaydeder. Bu kayıtlı klasörlerin her biri, Exchange Server çalıştıran sunucudaki objtFolder türü sınırına doğru sayılır. Bu, posta kutusu başına bir sınırdır.

"Belirtiler" bölümünde gösterilen 9646 olayında belirtildiği gibi, posta kutusu başına objtFolder nesneleri için varsayılan sınır 500'dür.

500'den fazla klasör içeren paylaşılan bir posta kutusunu önbelleğe alırsanız, bu sınır tükenir ve "Belirtiler" bölümünde belirtilen sorunlarla karşılaşabilirsiniz.

Ayrıca, çok sayıda Ortak Klasör sık kullanılanları objtFolder nesne sınırının tükenmesine katkıda bulunabilir.

Microsoft Exchange Server 2007'de izin verilen en fazla sunucu kaynağı paylaşımı hakkında daha fazla bilgi için bkz. Kullanıcı izin verilen en fazla sunucu paylaşımını kullanıyor.

Exchange Server 2010 posta kutusu deposu oturum sınırları hakkında daha fazla bilgi için aşağıdaki Microsoft web sitelerine gidin:

Bir posta kutusunda veya klasörde bulunan klasörlerin ve alt klasörlerin sayısını belirlemek için Get-MailboxFolderStatistics cmdlet'ini çalıştırın.