使用 Server-Side 同步處理時,Microsoft Dynamics 365 中發生 401 未經授權的例外狀況

本文提供當您在 Dynamics 365 中使用 Server-Side 同步處理時所發生錯誤的解決方案。

適用於:Microsoft Dynamics 365
原始 KB 編號: 3212785

重要事項

如果您使用 Exchange Online,而此錯誤發生在 2022 年 10 月 1 日之後,這可能是因為停用基本身份驗證所造成。 如需如何在有限的時間內暫時再次啟用基本身份驗證的詳細資訊,請參閱搭配使用基本身份驗證與 Exchange Online

徵狀

當您在 Dynamics 365 中使用 Server-Side 同步處理時,您會收到下列其中一個錯誤:

  • 無法傳送電子郵件訊息「測試訊息」。 請確定信箱信箱 <名稱> 中指定的認證正確無誤,而且有足夠的許可權可傳送電子郵件。 然後,啟用信箱以進行電子郵件處理。
  • 無法同步處理約會、聯繫人和工作。 請確定信箱信箱 <名稱> 中指定的認證正確無誤,而且有足夠的許可權。 然後,啟用約會、聯繫人和工作同步處理的信箱。
  • 無法接收信箱<的 Email信箱名稱>。 請確定信箱中指定的認證正確無誤,而且有足夠的許可權可接收電子郵件。 然後,啟用信箱以進行電子郵件處理。

此訊息也包含下列錯誤碼:

Email 伺服器錯誤碼:Http 伺服器傳回 401 未經授權的例外狀況。

原因

這些錯誤可能會因為下列其中一個原因而發生:

  1. Dynamics 365 中信箱記錄的電子郵件位址與 Exchange 中信箱的電子郵件位址不符。

  2. 如果您使用 Dynamics 365 (在線) 與 Exchange Online,即使使用者的信箱位於 Exchange Online 中,如果您使用 Exchange Server (混合式) 配置檔,還是會發生此錯誤。

  3. 如果您使用 Dynamics 365 搭配 Exchange Online,如果用戶沒有 Exchange Online 授權,就會發生此錯誤。

  4. 如果您使用 Dynamics 365 (在線) 與 Exchange Online,如果您的 Dynamics 365 訂用帳戶與 Exchange Online 訂用帳戶不在相同的 Office 365 租使用者中,就會發生此錯誤。 使用 Exchange Online 電子郵件伺服器配置檔時,Dynamics 365 (在線) 和 Exchange Online 必須位於相同的 Office 365 帳戶/租使用者中。

  5. 如果您使用 Dynamics 365 (在線) 與 Exchange 內部部署,如果未針對 EWS 啟用基本身份驗證, (Exchange Web 服務) ,就會發生此錯誤。

  6. 已刪除的使用者或信箱稍後會使用相同的電子郵件位址重新建立。

    當您嘗試測試並啟用信箱時,可能會看到 NoUserFoundWithGivenClaims 訊息包含在錯誤層級警示中。 您也可能會看到詳細數據區段顯示的警示:「使用者不存在於標識符為 『User ID>』< 的租使用者中」。

解決方案

若要修正此問題,請使用下列步驟:

  1. 確認信箱記錄在 Dynamics 365 中的電子郵件位址符合 Exchange 中的電子郵件位址。 此錯誤包含 Dynamics 365 中信箱記錄的連結。 您可以使用此連結快速驗證 [Email 位址] 欄位。

  2. 如果您使用 Dynamics 365 (在線) 與 Exchange Online,請確定您使用的是 Exchange Online 電子郵件伺服器設定檔。 僅針對在 Exchange 內部部署中具有信箱的使用者,使用 Exchange Server (混合式) 配置檔。

  3. 如果您使用 Dynamics 365 與 Exchange Online,請確認使用者具有 Exchange Online 授權。 如需在 Office 365 中指派授權的詳細資訊,請參閱新增用戶並同時指派授權

  4. 如果您使用 Dynamics 365 (在線) 與 Exchange Online,請確認在線 Dynamics 365 () 和 Exchange Online 位於相同的 Office 365 帳戶/租使用者中。

  5. 如果您使用與 Exchange 內部部署 Dynamics 365 (在線) ,請確認已啟用 EWS (Exchange Web 服務) 的基本身份驗證。 如需詳細資訊,請參閱連線 Dynamics 365 (在線) 以 Exchange Server (內部部署) 的必要條件一節。

  6. 如果稍後使用相同的電子郵件位址重新建立已刪除的使用者或信箱:

    1. 請確定先前現有的使用者或信箱已永久刪除。 根據預設,從 Microsoft Entra ID 刪除的用戶可以在 30 天內還原其帳戶。 如需詳細資訊,請參閱 永久刪除使用者
    2. 確認沒有任何使用者或信箱使用相同的電子郵件地址之後,您可以嘗試測試並再次啟用信箱。 如果您仍然收到錯誤訊息,問題可能是快取的結果所造成。 最多可能需要 72 小時才能清除快取。 如果您無法等候 72 小時,請連絡 Microsoft 支援服務