UCI 儀錶板不會在 2003.5 版之後載入

本文提供UCI儀錶板在2003.5版之後不會載入的問題解決方案。

適用於:Microsoft Dynamics 365 Customer Engagement Online
原始 KB 編號: 4558635

徵狀

更新至 2003.5 版之後,已設定為使用自定義控件之子格的儀錶板 (例如,可編輯的網格線) 不會在 UCI 中載入。

儀錶板可能卡在載入微調器,或顯示一般錯誤訊息:

(」發生錯誤。如需詳細數據,請參閱技術詳細數據 ) 。

原因

當儀錶板上有一個子格已設定為使用自定義控件,但並非所有外型規格時,就會造成此問題。 如果有自定義控件元件元件,但並非所有外型規格都有一個,則最後會是無法載入儀錶板的未處理 Null 例外狀況。

例如,控件元件可能如下所示:

顯示控件元件元件的螢幕快照。

或者,可能是因為控件元件組態未用於任何外型規格,例如:

未使用之子格自定義控件元件元件的螢幕快照。

解決方案

2004.3 版已修正 Bug。 不過,客戶可以藉由為所有外型規格新增控件元件元件,更快解決此問題。

在某些情況下,所使用的自定義控件可能不允許針對所有外型規格進行設定 (例如,無法針對手機外形規格) 設定可編輯的網格線,或客戶可能想要針對某些外型規格使用預設的只讀網格線。 在這些情況下,此因應措施仍然適用,因為只讀網格線也可以選擇為自定義控件元件元件元件。

例如,上述 [ 原因 ] 區段中的第一個控件組態可以變更為類似這樣的設定,以減輕問題:

此螢幕快照顯示所有外型規格的子格自定義控件元件元件元件。

或者,如果發生此問題是因為未在任何外型規格上使用的控件元件元件,則可以移除該控件元件元件。