在 2019 年 1 月 8 日左右,大量授權 Windows 7 Service Pack 1 KMS 用戶端上的啟用失敗和 (不是正版) 通知

本文提供使用者從 2019 年 1 月 8 日 10:00 UTC 開始或之後,可能會收到 Windows 啟用或「Windows 不是正版」通知的問題解決方案。

適用於:Windows 7 Service Pack 1
原始 KB 編號: 4487266

摘要

本文適用於大量授權的 Windows 7 Service Pack 1 裝置,這些裝置使用金鑰管理服務 (KMS) 啟用,並已安裝 KB 971033 更新。 某些使用者可能會從 2019 年 1 月 8 日 UTC 10:00 開始或之後收到 Windows 啟用或「Windows 不是正版」通知。

在 2019 年 1 月 9 日,我們還原了對 Microsoft 啟用和驗證伺服器所做的變更。 對於繼續報告啟用和「非正版」通知的裝置,您應該依照解決一節中的步驟移除 KB 971033

支援大量授權啟用的 Windows 版本包括:

  • Windows 7 專業版
  • Windows 7 專業版 N
  • Windows 7 專業版 E
  • Windows 7 企業版
  • Windows 7 企業版 N
  • Windows 7 企業版 E

對於在 2019 年 1 月 8 日左右發生 Microsoft 啟用和驗證伺服器變更所造成的啟用和「非正版」錯誤的 Windows 版本,建議您遵循標準啟用疑難解答。

徵狀

  1. 登入之後,您會收到 Windows 不是正版 的錯誤訊息。

    Windows 不是正版錯誤訊息的螢幕快照。

  2. A 此 Windows 複本不是正版 浮浮水印出現在 Windows 桌面右下角的黑色背景。

    浮浮浮水印的螢幕快照會出現在 Windows 桌面的右下角。

  3. 輸出 slmgr /dlv 會報告錯誤0xC004F200。

    命令輸出的螢幕快照,其中報告錯誤0xC004F200。

  4. 使用 命令進行的啟用 slmgr /ato 失敗,並傳回下列訊息:

    Windows 正在非正版通知期間內執行。 執行 『slui.exe』 以上線並驗證 Windows。

    使用 命令後傳回之訊息的螢幕快照。

  5. 下列事件會記錄在事件記錄檔中。

事件記錄檔 事件來源 事件識別碼 描述
應用程式 Microsoft-Windows-Security-SPP 8209 針對應用程式標識碼 55c92734-d682-4d71-983e-d6ec3f16059f,將正版狀態設定為非正版 (0x00000000)
應用程式 Microsoft-Windows-Security-SPP 8208 取得正版票證失敗 (hr=0xC004C4A2) 範本標識碼 66c92734-d682-4d71-983e-d6ec3f16059f
應用程式 Windows 啟用技術 13 正版驗證結果:hrOffline = 0x00000000、hrOnline =0xC004C4A2
應用程式 Microsoft-Windows-Security-SPP 8196 授權啟用排程器 (sppuinotify.dll) 無法自動啟用。 錯誤碼:0xC004F200:

原因

Microsoft 啟用和驗證的最近更新無意中造成已安裝 KB971033 之大量授權 Windows 7 用戶端發生「非正版」錯誤。 變更於 2019 年 1 月 8 日 10:00:00 UTC 推出,並在 2019 年 1 月 9 日 4:30:00 UTC 還原。

注意事項

此時間會與 2019 年 1 月 8 日星期二發行的 “1B” 2019 年 1 月更新 (KB 4480960KB 4480970) 一起發行。 這些事件無關。

已安裝 KB971033 但未在 2019 年 1 月 8 日 UTC (10:00:00 變更期間發生此問題的 Windows 7 裝置) ,以及該變更的重新發行時間 (2019 年 1 月 9 日 4:30:00 UTC,) 不應遇到本文所述的問題。

KB971033 包含下列文字:

注意 對於使用密鑰管理服務 (KMS) 或多重啟用密鑰 (MAK) 大量啟用的企業客戶,我們通常建議您不要在其參照映射或已部署的計算機中安裝此更新。 此更新是以使用 RETAIL 啟用的 Windows 消費者安裝為目標。」

強烈建議您從所有大量授權的 Windows 7 裝置卸載 KB971033 。 這包括目前不受徵 一節中所述問題影響的裝置。

解決方案

若要判斷是否已安裝 KB 971033 ,請使用下列其中一種方法。

  • 開啟 控制台 (控制台 中的 > [已安裝 匯報] 專案 Windows Update>檢視已安裝 匯報) 的更新>歷程記錄,然後在清單中尋找 [Microsoft Windows (KB971033) 更新]。

  • 以系統管理員身分在命令提示字元視窗中執行下列命令,然後在結果中尋找 “Microsoft-Windows-Security-WindowsActivationTechnologies-package~31bf3856ad364e35~amd64~~7.1.7600.16395”:

    dism /online /get-packages
    
  • 在命令提示字元中執行下列命令,然後查看結果以取得 KB 971033 已安裝的指示:

    wmic qfe where HotFixID="KB971033"
    
  • 在 Windows PowerShell 中執行下列命令,然後查看結果以取得 KB 971033已安裝的指示:

    Get-Hotfix -id KB971033
    

    如果目前已安裝 KB 971033 ,請使用下列其中一種方法來移除更新。 建議您在移除更新之後重新啟動系統。

  • 在 控制台 (控制台 的 [已安裝 匯報] 專案中 >Windows Update>檢視已安裝 匯報) 的更新歷程>記錄,以滑鼠右鍵按兩下 [Microsoft Windows (KB971033) 的更新],然後選取 [卸載]

  • 以系統管理員身分在命令提示字元視窗中執行下列命令:

    wusa /uninstall /kb:971033
    
  • 以系統管理員身分在命令提示字元視窗中執行下列命令:

    dism /online /Remove-Package /PackageName:Microsoft-Windows-Security-WindowsActivationTechnologies-Package~31bf3856ad364e35~amd64~~7.1.7600.16395
    

卸載 KB 971033 之後,或在不再顯示為已安裝之後,請重建啟用相關的檔案,然後以系統管理員身分在命令提示字元視窗中執行下列命令來重新啟用系統:

net stop sppuinotify
sc config sppuinotify start= disabled
net stop sppsvc
del %windir%\system32\7B296FB0-376B-497e-B012-9C450E1B7327-5P-0.C7483456-A289-439d-8115-601632D005A0 /ah
del %windir%\system32\7B296FB0-376B-497e-B012-9C450E1B7327-5P-1.C7483456-A289-439d-8115-601632D005A0 /ah
del %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform\tokens.dat
del %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform\cache\cache.dat
net start sppsvc
cscript c:\windows\system32\slmgr.vbs /ipk <edition-specific KMS client key>
cscript c:\windows\system32\slmgr.vbs /ato
sc config sppuinotify start= demand

注意事項

在第一個 cscript 命令中,將版本特定的 KMS 用戶端密鑰>取代<為實際金鑰。 如需詳細資訊,請參閱 KMS 用戶端安裝金鑰

下表列出每個 Windows 7 版本的 KMS 用戶端密鑰。

操作系統版本 KMS 用戶端安裝金鑰
Windows 7 專業版 FJ82H-XT6CR-J8D7P-XQJJ2-GPDD4
Windows 7 專業版 N MRPKT-YTG23-K7D7T-X2JMM-QY7MG
Windows 7 專業版 E W82YF-2Q76Y-63HXB-FGJG9-GF7QX
Windows 7 企業版 33PXH-7Y6KF-2VJC9-XBBR8-HVTHH
Windows 7 企業版 N YDRBP-3D83W-TY26F-D46B2-XCKRJ
Windows 7 企業版 E C29WB-22CC8-VJ326-GHFJW-H9DH4

注意事項

  • 包含 KMS 用戶端安裝金鑰的文稿必須以對應的作業系統版本為目標。
  • 對於未安裝 KB 971033 但遇到徵 一節中所述問題的服務,您也可以重建啟用相關的檔案,並使用重新啟用命令清單中所述的腳本來重新啟用系統。

資料收集

若您需要 Microsoft 支援,建議您按照使用 TSS 收集部署相關問題的資訊所述步驟來收集資訊。