使用 PEC 编码时,Email无法同步到 Microsoft Dynamics 365
本文提供了电子邮件在使用 PEC 编码时无法同步到 Microsoft Dynamics 365的问题的解决方案。
适用范围:Microsoft Dynamics CRM
原始 KB 编号: 4490718
简介
什么是 PEC 电子邮件?
PEC 电子邮件是在某些国家/地区中使用的认证电子邮件,其法律有效性与注册电子邮件 (s/mime) 相同。
S/MIME (安全/多用途 Internet 邮件扩展) 是一种广泛接受的方法,更确切地说是用于发送数字签名和加密邮件的协议。
S/MIME 允许你加密电子邮件,并对它们进行数字签名。
症状
PEC 电子邮件不会与 Server-Side 同步或Email路由器同步。
原因
Server-Side 同步和Email路由器使用 Exchange Web 服务连接到Exchange Server。
PEC 和RFC6109不会通过 REST 或 SOAP 使用 API,因此 Server-Side 同步和Email路由器将无法正确同步这些电子邮件。
解决方案
加密电子邮件时,它会创建一个令牌,该令牌将发送给该电子邮件的收件人。
这种一对一关系使用户能够向其他用户发送电子邮件并加密。
发送加密电子邮件时会发生什么情况:
由于 Dynamics 是第三方应用程序,因此当它尝试访问电子邮件时,它只会收到处于加密状态的电子邮件。
由于Dynamics 365中不存在令牌,因此不会解密电子邮件。
- 唯一密码可加密电子邮件。
- 电子邮件编码为密码文本。
- 发送和接收Email。
- 接收方输入密码密钥来解码消息。
PEC 和RFC6109不会通过 REST 或 SOAP 使用 API,因此 Server-Side 同步和Email路由器不支持此电子邮件类型进行同步。
若要将此电子邮件与Dynamics 365组织同步,必须从电子邮件中删除加密,这可以通过转发电子邮件来实现。