本文提供了解决方案,用于解决在尝试将 Dynamics CRM Online 连接到本地部署的 Exchange 时发生的错误。
适用于: Microsoft Dynamics CRM Online
原始 KB 数: 3189622
现象
在 Microsoft Dynamics CRM Online 和 Exchange Server(本地)之间配置服务器端同步时,尝试启用邮箱后会收到以下错误之一:
- 无法发送电子邮件“测试邮件”,因为关联电子邮件服务器配置文件中指定的凭据不正确或没有足够的权限发送电子邮件。 已通知电子邮件服务器配置文件<名称> 的所有者。
- 无法接收电子邮件,因为关联电子邮件服务器配置文件中指定的凭据不正确或没有足够的权限接收电子邮件。 邮箱 <邮箱名称> 未同步。 有关此通知的信息将发布到电子邮件服务器配置文件<名称>所有者的警报墙上。
原因
如果未为基本身份验证启用 Exchange Web 服务(EWS),则可能会出现此错误。
决议
在 EWS (Exchange Web Services) 目录中启用基本身份验证。 基本身份验证不是 EWS 的默认值,因此需要确保启用此身份验证。
有关基本身份验证的详细信息,请参阅:
- Exchange Server 2010: 配置基本身份验证
- Exchange Server 2010: Exchange 相关虚拟目录的默认身份验证设置
- Exchange Server 2013: Exchange 中的身份验证和 EWS
- Exchange Server 2013:Exchange 虚拟目录的默认设置
详细信息
为上述错误之一选择“详细信息”时,可能会看到详细信息,例如以下示例:
-
ActivityId: <GUID>
>错误:System.Net.WebException:请求失败,HTTP 状态为 401:不允许匿名请求。
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndFindItem(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.FindItemsStep.EndCall()
at Microsoft.Crm.Async.EmailConnector.ExchangeIncomingEmailProviderStep.EndOperation() -
ActivityId: GUID<>错误: >System.Net.WebException: 请求失败,HTTP 状态为 401:不允许匿名请求。
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
at Microsoft.Crm.Sync.EmailConnector.ExchangeServiceBinding.EndCreateItem(IAsyncResult asyncResult)
at Microsoft.Crm.Sync.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem()