在 CRM 中不存在的发件人的电子邮件上选择“在 CRM 中跟踪”时,你无权访问这些记录错误

本文提供了对来自 CRM 中不存在的发件人的电子邮件选择“在 CRM 中 跟踪 ”时发生的错误的解决方案。

适用于:2015 Microsoft Dynamics CRM、Microsoft Dynamics CRM 2016
原始 KB 编号: 3140762

症状

在 Outlook 的 Microsoft Dynamics CRM 中选择“在 CRM 中跟踪”,并且电子邮件来自 CRM 中不作为记录存在的发件人,则会发生以下错误:

“你无权访问这些记录。 请与Microsoft Dynamics CRM管理员联系。项目名称 = <电子邮件>的主题”

原因

Microsoft Dynamics CRM中的用户记录缺少队列实体的读取访问权限。 Microsoft 已了解此问题,并正在调查潜在的解决方法。 在此期间,可以使用“解决方法”部分中提供的解决方法。

解决方案

以具有系统管理员角色的用户身份登录Microsoft Dynamics CRM。 找到分配给用户的安全角色。 在安全角色的“ 核心记录 ”选项卡上,授予队列实体的读取访问权限。

更多信息

如果捕获了如何为 Outlook 客户端启用Microsoft Dynamics CRM跟踪,则会记录以下信息:

主体用户 (Id={GUID},type=8) 缺少 prvReadQueue 权限 (Id=<ID>)