本文针对在 UI 流执行期间因安全策略无法启动流的问题,提供了一个解决方案。
适用于: Microsoft Dynamics CRM
原始 KB 数: 4564550
现象
运行包含桌面流的流时,即使目标设备安装了桌面流,它也会失败并出现以下错误。
无法连接到您的计算机上运行的桌面流。 请确保 Power Automate Desktop 已安装并运行。
重启时(例如,设备重启),Windows 服务 uiflowservice 在事件 ID 为 7041 的 Windows 日志\系统的事件查看器中失败并出现以下错误:
此服务帐户没有所需的用户权限“以服务身份登录”。
尝试手动启动 uiflowservice 时,启动失败并显示消息:
Windows 无法在本地计算机上启动 UIFlowService 服务。 错误 1069:由于登录失败,服务未启动。
原因
UI 流服务(uiflowservice)未在目标计算机上运行,因为服务使用的帐户不会通过手动配置或域组策略授予 登录即服务 授权。
决议
目标设备
确保 UI 流服务在目标计算机上的本地服务中运行。
确保 UI 流服务帐户 NT SERVICE\UIFlowService 或常规服务帐户 NT SERVICE\ALL SERVICES 已包含在本地安全策略设置中的作为服务登录策略中。
更多详细信息 更多详细信息 如果它们都不存在,并且无法添加到本地“作为服务登录”策略中,则需要在域组策略中添加其中一个。 转到 已加入域的服务器。
这表示策略在域控制器上设置为组策略:
确保服务帐户 NT SERVICE\UIFlowService 和常规服务帐户 NT SERVICE\ALL SERVICES 不会作为 本地安全策略设置的服务 策略出现在“拒绝登录”中。
更多详细信息 更多详细信息 如果无法从本地“拒绝作为服务登录”策略中删除,则需要从域组策略中删除它们。 转到 已加入域的服务器
这表示策略在域控制器上设置为组策略:
已加入域的服务器
如果您的服务器已加入域,并且 以服务身份登录 或 拒绝以服务身份登录 策略由域管理,请查看域控制器上的以下步骤。 可能需要联系域管理员,执行以下步骤:
确保 UI 流服务帐户 NT SERVICE\UIFlowService 或常规服务帐户 NT SERVICE\ALL SERVICES 存在于组安全策略设置中的 作为服务登录策略。
更多详细信息 更多详细信息 UI 流服务使用的虚拟帐户“NT SERVICE\UIFlowService”是在安装 Power Automate Desktop 期间创建的(安装 UI 流服务时)。 如果域中不存在,请按照此过程在域控制器上创建它:
1。 在域控制器
2 上安装 Power Automate Desktop。 安装不需要成功,即使遇到错误条件,也会在域中创建虚拟帐户。
如果出现错误,请检查帐户“NT SERVICE\UIFlowService”是否具有域控制器和目标服务器策略上所需的所有访问权限,然后再取消或中止安装。
3. 现在,“NT SERVICE\UIFlowService”帐户在域中可用,可以将其添加到组策略设置中,并且将在已加入域的服务器中可见。UI 流服务,其虚拟帐户安装在域控制器上。
将“NT SERVICE\UIFlowService”添加到域组“登录即服务”策略
在确保“NT SERVICE\UIFlowService”帐户在相关组策略中存在后,您可以从域控制器中卸载 Power Automate Desktop,因为该服务仅在目标计算机上需要。 确保 UI 流服务帐户 NT SERVICE\UIFlowService 和常规服务帐户 NT SERVICE\ALL SERVICES 均未出现在组策略设置的 “拒绝作为服务登录”策略 中。
更多详细信息 更多详细信息 如果帐户“NT SERVICE\UIFlowService”或帐户“NT SERVICE\ALL SERVICES”位于“拒绝以服务身份登录”策略中,则需要编辑域组策略。