知识库文章不支持多语言搜索

本文提供有关最初用英语创作的知识文章有时无法使用其他语言(如中文)的搜索词来发现的问题的故障排除步骤。

症状

在 Dynamics 365 客户服务中搜索知识文章时,可能会遇到以下问题:

  • 使用其他语言的搜索词(例如中文)无法一致地发现用英语创作的知识文章。
  • 某些文章是使用多语言搜索词成功检索的,而另一些文章则不是。

原因

此问题可能与知识文章的语言首选项或翻译配置相关。 具体说来:

  1. 知识文章的首选语言可能与搜索查询的语言不匹配。
  2. 知识文章的翻译可能尚未正确配置或启用。

故障排除步骤

验证知识文章的首选语言

  1. 打开多语言搜索中未显示的知识文章。

  2. 检查文章的首选语言设置。 确保它与最初创作文章的语言匹配。

  3. 如果首选语言不正确, 请将其更新为正确的语言 并保存更改。

为知识文章配置翻译

  1. 打开多语言搜索中未显示的知识文章。

  2. 检查是否已为文章配置翻译。

  3. 如果未配置翻译, 请设置文章的翻译语言

  4. 保存并 发布知识文章

详细信息

有关配置语言首选项和翻译的详细步骤,请参阅: