SLA 未应用于案例

本文介绍服务级别协议(SLA)可能无法应用于案例的不同场景,以及解决这些协议的步骤。

方案 1:未设置默认 SLA

原因

如果未设置默认 SLA,则 SLA 不会应用于事例。

解决方法

执行以下步骤,确保将 SLA 设置为默认 SLA:

  1. 在客户服务管理中心,转到 服务级别协议
  2. 操作中选择“服务条款”。 服务条款页面将显示。
  3. 服务级别协议 (SLA) 部分,选择管理
  4. 选择所需的 SLA,然后从功能区选择设为默认选项。

方案 2:SLA KPI“适用来源”字段值为 null

原因

迁移工具可能无法在迁移到统一接口期间设置适用的 SLA KPI 字段值。 或者,SLA KPI “适用发件人 ”字段设置为未设置为任何值的自定义字段。

解决方法

确保“SLA KPI 适用的发件人 ”字段值未设置为 null。 它应设置为某些值。

方案 3:SLA 项的“适用时间”条件和实体条件不匹配

原因

SLA 项 在条件和实体条件不匹配时 适用,因为以下问题之一:

  • 字符串值与属性不匹配。
  • SLA 项中使用具有相同名称的不同属性。
  • 选项 文本值相同,但 GUID 不同。

解决方法

若要解决此问题,请检查 SLA 项在 条件和实体条件时 适用,以确保上述问题不会发生。

方案 4:在从旧接口迁移到统一接口期间,无法更新 SLA 项的“适用时间”条件

原因

将 SLA 从旧版迁移到统一接口后,当 SLA 项的条件时,它可能无法填充“适用”。

解决方法

若要解决此问题,请确保在从旧接口迁移到统一接口后条件不为空时 SLA 项适用。

方案 5:出现“SdkMessageProcessing 步骤必须处于活动状态”错误

原因

这些步骤 SdkMessageProcessing 可能处于非活动状态。

解决方法

若要解决此问题,请激活以下步骤 SdkMessageProcessing (如果它们处于草稿或非活动状态)。

  • PreOperationIncidentCreateEntitlement (6742a23a-7102-e711-8112-00155db32104)
  • PreOperationIncidentUpdateEntitlement (9e1588ed-62ff-e611-810f-00155db32104)
  • PostOperationIncidentUpdateEntitlement (a468c44e-c204-e711-80ca-02155dc812c3)
  • PostOperationIncidentCreateEntitlement (8fbadfbe-c104-e711-80ca-02155dc812c3)

若要搜索步骤,请执行以下操作 SdkMessageProcessing

  1. 导航到 自定义项。
  2. 选择“ 自定义系统>SDK 消息处理步骤”。
  3. 搜索 SdkMessageProcessing 上述步骤。
  4. 如果步骤处于停用状态,请选择“激活”按钮。

方案 6:“服务配置设置”中的“禁用 SLA”未设置为“否”

原因

服务配置设置中的“禁用 SLA”设置可能设置为“是”。

解决方法

检查服务配置设置中的“禁用 SLA”设置。 如果设置为“是”,则将其切换到“否”。 有关详细信息,请参阅 服务配置设置

方案 7:出现“工作流必须处于已发布状态”或“操作必须处于发布状态”错误

原因

工作流可能处于草稿或非活动状态。

解决方法

若要解决此问题,请激活 SLA 项的流(如果处于非活动状态)。 有关如何激活流的详细信息,请参阅 “新式流对 ExecuteWorkflow 无效”错误

方案 8:“空日历计划”。 检查是否正确设置了工作时间“错误

原因

出现此问题的原因是 SLA 项目的工作时间与配置为使用旧版 Web 客户端日历界面的日历相关联。 因此,SLA 不会应用于统一接口中后退 的适用 条件。 你需要检查 SLA 项目的工作时间是否配置了旧版 Web 客户端日历。

解决方法

若要解决此问题,请在统一接口中创建日历,并在 SLA 项中更改日历。 或者,在统一界面中打开旧日历,然后选择“ 保存并关闭”。 有关详细信息,请参阅 设置日历