某些用户的约会不会从 Microsoft Dynamics 365同步到 Exchange

本文针对某些用户的约会无法从 Microsoft Dynamics 365同步到 Microsoft Exchange 的问题提供了解决方案。

适用于:Microsoft Dynamics 365 Customer Engagement Online
原始 KB 编号: 4494491

症状

某些用户的约会不会从 Microsoft Dynamics 365同步到 Microsoft Exchange。 如果查看 Microsoft Dynamics 365中相应邮箱的“警报”部分,会看到以下警报消息:

邮箱邮箱名称>的<约会、联系人和任务无法同步。 已通知关联的电子邮件服务器配置文件 <名称> 的所有者。 系统将稍后重试。
Email服务器错误代码:Exchange.server 返回 383 错误。

原因

Microsoft 知道 Exchange Web Services API 存在问题 ,如果使用以下时区之一,可能会导致此错误:

  • (GMT-05:00) 切图马尔 - 东部标准时间 (墨西哥)
  • (GMT-03:00) 蒙得维的亚 - 蒙得维的亚标准时间
  • (GMT+01:00) 卡萨布兰卡 - 摩洛哥标准时间
  • (GMT+02:00) 开罗 - 埃及标准时间
  • (GMT+02:00) 加里宁格勒 - 加里宁格勒标准时间
  • (GMT+02:00) 温得和克 - 纳米比亚标准时间
  • (UTC+02:00) 喀土穆 - 苏丹标准时间
  • (GMT+03:00) 巴格达 - 阿拉伯标准时间
  • (UTC+03:00) 伊斯坦布尔 - Türkiye 标准时间
  • (格林尼治时间+03:00) 明斯克 - 白俄罗斯标准时间
  • (GMT+04:00) 阿斯特拉罕,乌里扬诺夫斯克 - 阿斯特拉罕标准时间
  • (GMT+04:00) 巴库 - 阿塞拜疆标准时间
  • (GMT+04:00) 伊热夫斯克,萨马拉 - 俄罗斯时区 3
  • (GMT+04:00) 莫斯科,圣彼得堡,伏尔加格勒 - 俄罗斯标准时间
  • (GMT+04:00) 埃里温 - 高加索标准时间
  • (GMT+05:00) 叶卡捷琳堡 - 叶卡捷琳堡标准时间
  • (GMT+07:00) 巴尔瑙尔,Gorno-Altaysk - 阿尔泰标准时间
  • (GMT+07:00) Hovd - W. 蒙古标准时间
  • (GMT+07:00) 克拉斯诺亚尔斯克 - 北亚标准时间
  • (GMT+07:00) 新西伯利亚 - 北中亚标准时间
  • (GMT+07:00) Tomsk - Omsk 标准时间
  • (GMT+07:00) Tomsk - Tomsk 标准时间
  • (GMT+08:00) 伊尔库茨克 - 北亚东部标准时间
  • (GMT+09:00) 奇塔 - 跨贝加尔标准时间
  • (GMT+09:00) 雅库茨克 - 雅库茨克标准时间
  • (GMT+10:00) 弗拉迪沃斯托克 - 弗拉迪沃斯托克标准时间
  • (格林尼治时间+11:00) 布干维尔岛 - 布干维尔标准时间
  • (GMT+11:00) Chokurdakh - 俄罗斯时区 10
  • (GMT+11:00) 马加丹 - 马加丹标准时间
  • (GMT+11:00) 诺福克岛 - 诺福克标准时间
  • (GMT+11:00) 萨哈林 - 萨哈林标准时间
  • (GMT+12:00) Anadyr, Petropavlovsk-Kamchatsky - 俄罗斯时区 11

解决方案

Microsoft 正在调查此问题的解决方案。 在此期间,可以通过在 Microsoft Dynamics 365中更改用户的时区设置来解决此问题:

  1. Microsoft Dynamics 365用户可以通过选择 Microsoft Dynamics 365右上角的齿轮图标,然后选择“选项”来访问其个人选项。

  2. 如果 时区 值是上述“原因”部分中列出的时区之一,请将该值更新为另一个时区,该时区的时间偏移量相同,但不在本文的“原因”部分的列表中。

    例如:如果使用 (GMT-05:00) Chetumal,可以尝试切换到 (GMT-05:00) 哈瓦那。

  3. 选择“确定”。

  4. 约会应在邮箱的下一个同步周期同步,这可能需要 15-30 分钟。