在 Microsoft Dynamics 365中测试和启用邮箱时,在发送电子邮件时出现邮箱错误

本文提供了在 Microsoft Dynamics 365中尝试测试和启用邮箱时发生的错误的解决方案。

适用于:Microsoft Dynamics 365
原始 KB 编号: 4092737

症状

尝试在 Microsoft Dynamics 365 中测试和启用邮箱时,会收到以下错误:

“在连接到电子邮件服务器时,为邮箱发送电子邮件时出错,”邮箱现在已连接到 Dynamics 365”。 已通知关联的电子邮件服务器配置文件 <的所有者邮箱名称> 。 系统稍后将尝试再次发送电子邮件。
Email服务器错误代码:Web 服务器返回 ConnectFailure 异常。”

原因

如果Dynamics 365无法连接到电子邮件服务器,则会发生此错误。

如果将 Dynamics 365 Online 与本地 Exchange 配合使用,则防火墙不允许从联机Dynamics 365通信,则可能会出现此情况。

如果使用 SMTP/POP3 提供程序(如 Gmail),则如果电子邮件服务器配置文件的“高级”部分中的端口值不正确,则可能会出现这种情况。

解决方案

使用本地 Exchange Dynamics 365 Online
验证防火墙是否允许从联机Dynamics 365进行通信。 有关Dynamics 365可能使用的 IP 地址范围的列表,请参阅 Microsoft Dynamics CRM Online IP 地址范围

POP3/SMTP 提供程序,例如 Gmail
验证是否指定了正确的端口:

  1. 导航到“设置”Email“配置”,然后选择“Email服务器配置文件”。

  2. 打开邮箱会议使用此错误的 Email 服务器配置文件。

    注意

    还可以在错误消息中选择Email服务器配置文件的名称。 它显示为超链接,将打开正确的Email服务器配置文件记录。

  3. 选择“高级”

  4. 验证 “传入端口 ”和“ 传出端口 ”值,然后选择“ 保存”。

    注意

    有关连接到 SMTP 服务时要使用的正确端口,请参阅电子邮件提供商的文档。 对于 Gmail,传入 POP3 端口为 995,传出 SMTP 端口为 587。

  5. 选择“ 邮箱 ”,然后选择收到错误的邮箱。

  6. 选择“ 测试 & 启用邮箱 ”按钮。

  7. 测试完成后,如果结果未显示为“成功”,请打开邮箱记录并查看 “警报 ”部分。