错误代码:2147812097许可证无效:此应用程序需要许可证,并且未分配适当的许可证

本文提供了一个解决方案,用于解决尝试访问需要适当许可证且未分配的应用模块(业务应用程序)时发生的错误。

适用于: Microsoft Dynamics CRM Online
原始 KB 数: 4548022

现象

当用户尝试访问需要适当许可证且未分配的应用模块(业务应用程序)时,用户会收到以下错误消息:

此应用需要许可证,并且你没有相应的许可证才能访问此应用。 请与管理员联系,根据提供的详细信息分配相应的许可证。
详细信息
用户没有用于访问此应用模块 uniqueName=< 唯一名称>的许可证,其 ID>=<Id 来自 publisher=<publisher 名称>。 服务计划之一需要许可证: <服务计划名称>: <服务计划 ID>。 有关更多详细信息,请参阅指向此 KB> 的文章<链接。

原因

当应用程序需要许可证且管理员未将相应的许可证分配给应用程序的用户(s)时,会出现此问题。

例如,如果具有团队成员许可证的用户尝试访问客户服务中心应用程序,用户将看到此错误:

此应用需要许可证,并且你没有相应的许可证才能访问此应用。 请与管理员联系,根据提供的详细信息分配相应的许可证。

详细信息

用户没有任何许可证可从 publisher= dynamics365customerengagement 访问此应用模块 uniqueName= Customerservicehub。 其中一个服务计划需要许可证:“Dynamics 365 for Customer Service: <GUID>

解决方法

解决方法是联系管理员并请求分配许可证。 错误详细信息中存在许可证名称和应用程序名称。

Dynamics 团队成员许可证错误的屏幕截图。

访问自定义应用:

若要访问自定义应用(画布或模型驱动),需要分配 Dynamics 365 Enterprise 或 Professional 许可证、 Power AppsPer 用户 计划或环境才能获得 Power Appsper 应用 计划(即 应用通行证)。 有关 Power Appsper 应用计划(即应用通行证)的详细信息,请参阅关于每个应用计划的 Power Apps。