在 Microsoft Dynamics 365 中创建传入电子邮件时出错
本文提供了在 Microsoft Dynamics 365 中创建传入电子邮件时发生的错误的解决方案。
适用于:Microsoft Dynamics 365
原始 KB 编号: 4053783
症状
以下警报记录在 Microsoft Dynamics 365 中的邮箱记录中:
“在 Microsoft Dynamics 365 中为邮箱<邮箱名称>创建传入电子邮件<Email主题>时出错。”
如果在警报中选择“ 查看详细信息” ,则会看到以下附加信息:
“Email服务器错误代码:InvalidSender”
或者:
“Email服务器错误代码:InvalidForwardMailItem”
原因
原因 1:
如果警报包含文本 InvalidSender,则如果 Server-Side 同步无法跟踪电子邮件,因为邮件的“发件人”字段中没有有效的电子邮件地址,则会记录此邮件。
原因 2:
如果警报包含文本 InvalidForwardMailItem,则如果转发邮箱收到了电子邮件,但转发到转发邮箱的Dynamics 365邮箱未将电子邮件作为附件正确转发,或者该邮箱没有将“传入Email”选项设置为“转发邮箱”选项,则会记录此邮件。
解决方案
解决方案 1 (InvalidSender) :
- 在邮箱中找到相应的电子邮件。
- 验证“发件人”字段中是否有有效的电子邮件地址。
解决方案 2 (InvalidForwardMailItem) :
- 打开将电子邮件转发到转发邮箱的Dynamics 365邮箱记录。
- 验证“传入Email”设置(位于“同步方法”部分)是否已选择“转发邮箱”选项。 如果选择了另一个选项(如服务器端同步或Email路由器),则会解释记录此错误的原因。
- 如果邮箱已配置为使用“传入Email的转发邮箱”选项,请验证邮箱是否已正确配置为不仅将电子邮件转发到转发邮箱,而且配置为将电子邮件转发为附件。
更多信息
某些应用程序发送的自动电子邮件不包含“发件人”字段中的有效电子邮件地址。 例如,Outlook 中的“待筛选邮件”功能发送导致以下信息警报的消息:
“在 Microsoft Dynamics 365邮箱中创建传入电子邮件时出错”待筛选邮件移动了新的和不同的邮件”
可以放心地忽略此警报,它是信息级警报。 如果要避免记录信息级别警报,可以更改在“系统设置”中启用的警报类型。
- 作为具有系统管理员角色的用户,导航到“设置”,选择“Email配置”,然后选择“Email配置设置”。
- 向下滚动到 “配置警报 ”部分,并从“ 信息 ”复选框中删除所选内容。
- 选择“确定”。