UnknownIncomingEmailIntegrationError -2147220956 异常显示在 Microsoft Dynamics 365 中的服务器端同步警报中

本文提供了Microsoft Dynamics 365 邮箱记录中发生的错误的解决方案。

适用于: Microsoft Dynamics 365
原始 KB 数: 4471762

现象

类似于以下邮件的警告级别警报显示在 Dynamics 365 邮箱记录中:

“通过邮箱接收电子邮件时出现未知错误”[邮箱名称] ”。 已通知关联的电子邮件服务器配置文件 [配置文件名称] 的所有者。 系统稍后将尝试再次接收电子邮件。

电子邮件服务器错误代码: Exchange 服务器返回 UnknownIncomingEmailIntegrationError -2147220956 异常。

原因

错误代码 -2147220956 指示 IsvUnexpected 错误。 这通常表示自定义插件或工作流引发错误并导致创建项失败。

解决方法

以下步骤使用未能创建的电子邮件记录示例。 如果看到为其他类型的项目(如约会、联系人或任务)记录了此错误,可以通过将对电子邮件的引用替换为要排除故障的记录类型来应用相同的步骤类型。

检查是否有任何在创建电子邮件时同步运行的自定义插件或工作流。 如果插件或工作流导致错误,则服务器端同步不会创建电子邮件。 以下步骤可帮助你确定组织中是否存在在创建电子邮件期间运行的任何工作流或插件:

Workflow

  1. 在 Dynamics 365 Web 应用程序中,导航到 “设置” ,然后选择“ 进程”。

  2. 将视图更改为 “已激活的进程”。

  3. 在“主实体”列上排序,并查找“电子邮件”作为主要实体的任何行,将工作流作为类别。

    相反,可以使用网格中的筛选选项来筛选类别 = 工作流和主实体 = 电子邮件

  4. 打开符合上述条件的每个工作流(如果有)。

  5. 如果选择了“记录”选项,并且未选择“在后台运行此工作流”选项(建议)选项,则此工作流可能是原因。

    注意

    如果要排查约会、联系人或任务出现此类错误,还请检查工作流是否已配置为在更新该类型的记录期间运行。

  6. 选择页面左侧的“进程会话”部分,并查找与未成功创建的电子邮件相关的任何失败。

插件

  1. 在 Dynamics 365 Web 应用程序中,导航到“设置”、“自定义”,然后选择“自定义系统”。
  2. 选择 Sdk 消息处理步骤
  3. 主对象类型代码(SdkMessage 筛选器) 列进行排序,并查找电子邮件实体的任何行。
  4. 如果发现任何行和执行模式是同步的,则可能干扰电子邮件的创建。

如果问题一致地重现,并且可能暂时禁用工作流或插件作为测试,这可以让你确定工作流或插件是否是原因。