401 使用 Server-Side 同步时,Microsoft Dynamics 365 中发生未经授权的异常
本文提供了在 Dynamics 365 中使用 Server-Side 同步时发生的错误的解决方案。
适用于:Microsoft Dynamics 365
原始 KB 编号: 3212785
重要
如果使用 Exchange Online并且此错误发生在 2022 年 10 月 1 日之后,则可能是由于禁用了基本身份验证而导致的。 有关如何在有限时间内再次临时启用基本身份验证的详细信息,请参阅将基本身份验证与Exchange Online配合使用。
症状
在 Dynamics 365 中使用 Server-Side 同步时,会收到以下错误之一:
- 无法发送电子邮件“测试邮件”。 请确保邮箱 <邮箱名称> 中指定的凭据正确,并且有足够的权限发送电子邮件。 然后,启用邮箱以处理电子邮件。
- 约会、联系人和任务无法同步。 请确保邮箱 <邮箱名称> 中指定的凭据正确且具有足够的权限。 然后,为约会、联系人和任务同步启用邮箱。
- 无法接收邮箱<的Email邮箱名称>。 请确保邮箱中指定的凭据正确无误,并且有足够的权限来接收电子邮件。 然后,启用邮箱以处理电子邮件。
该消息还包括以下错误代码:
Email服务器错误代码:Http 服务器返回 401 未授权异常。
原因
这些错误可能由以下原因之一导致:
Dynamics 365中邮箱记录的电子邮件地址与 Exchange 中邮箱的电子邮件地址不匹配。
如果将Dynamics 365 (联机) 与 Exchange Online 配合使用,则如果使用Exchange Server (混合) 配置文件,即使用户的邮箱位于 Exchange Online 中,也可能发生此错误。
如果将 Dynamics 365 与 Exchange Online 一起使用,则如果用户没有Exchange Online许可证,则可能会出现此错误。
如果将Dynamics 365 (联机) 与 Exchange Online 配合使用,则如果Dynamics 365订阅与Exchange Online订阅不在同一Office 365租户中,则会发生此错误。 使用Exchange Online电子邮件服务器配置文件时,Dynamics 365 (联机) 和Exchange Online需要位于同一Office 365帐户/租户中。
如果将Dynamics 365 (联机) 与本地 Exchange 配合使用,则如果未为 EWS 启用基本身份验证, (Exchange Web Services) ,则会发生此错误。
已删除的用户或邮箱稍后使用相同的电子邮件地址重新创建。
尝试测试和启用邮箱时,你可能会看到 NoUserFoundWithGivenClaims 消息包含在错误级别警报中。 还可能会看到一条警报,其中详细信息部分显示“ID 为'用户 ID>'<的租户中不存在用户”。
解决方案
若要解决此问题,请使用以下步骤:
验证 Dynamics 365 中邮箱记录的电子邮件地址是否与 Exchange 中的电子邮件地址匹配。 此错误包括指向 Dynamics 365 中的邮箱记录的链接。 可以使用此链接快速验证“Email地址”字段。
如果将Dynamics 365 (联机) 与Exchange Online配合使用,请确保使用Exchange Online电子邮件服务器配置文件。 仅对本地 Exchange 中具有邮箱的用户使用Exchange Server (混合) 配置文件。
如果将 Dynamics 365 与 Exchange Online 配合使用,请验证用户是否具有Exchange Online许可证。 有关在 Office 365 中分配许可证的详细信息,请参阅同时添加用户和分配许可证。
如果将Dynamics 365 (联机) 与 Exchange Online 配合使用,请验证Dynamics 365 (联机) 和Exchange Online是否位于同一Office 365帐户/租户中。
如果将Dynamics 365 (联机) 与本地 Exchange 配合使用,请验证是否为 EWS (Exchange Web Services) 启用了基本身份验证。 有关详细信息,请参阅将联机Dynamics 365 () 连接到本地Exchange Server () 中的先决条件部分。
如果之后使用相同的电子邮件地址重新创建已删除的用户或邮箱:
- 确保以前存在的用户或邮箱已被永久删除。 默认情况下,从 Microsoft Entra ID 中删除的用户可以在 30 天内还原其帐户。 有关详细信息,请参阅 永久删除用户。
- 验证是否没有用户或邮箱使用相同的电子邮件地址后,可以尝试再次测试并启用邮箱。 如果仍收到错误消息,则问题可能是由缓存结果引起的。 清除缓存可能需要长达 72 小时。 如果无法等待 72 小时,请联系 Microsoft 支持部门。