配置Microsoft Dynamics CRM for Microsoft Office Outlook时出现 HResult 0x80004005错误

本文为尝试配置Microsoft Dynamics CRM for Microsoft Office Outlook时发生的 HResult 0x80004005 错误提供了解决方法。

适用于:Microsoft Dynamics CRM Online、Microsoft Office Outlook Microsoft Dynamics CRM 客户端、Microsoft Dynamics CRM 2016、Microsoft Dynamics CRM 2015、2013 Microsoft Dynamics CRM
原始 KB 编号: 3182535

症状

尝试配置Microsoft Dynamics CRM for Microsoft Office Outlook时,会收到以下错误:

“与 Microsoft Dynamics CRM 服务器通信时出现问题。 服务器可能不可用。 请稍后重试。 如果问题仍然存在,请与系统管理员联系。

HResult:0x80004005 microsoft.Interop.Mapi.CRcwMsgServiceAdmin.ConfigureMsgService...”

原因

如果 Outlook 安装出现问题,则可能会出现此错误。

解决方案

修复 Office 程序可能会解决此问题。

  1. 关闭所有正在运行的 Office 程序 (,例如 Outlook、Word 或 PowerPoint) 。
  2. 打开 Windows 控制面板并选择“程序和功能”。
  3. 在已安装的程序列表中,右键单击“ Microsoft Office”,选择“ 更改”,然后按照提示操作。

注意

如果使用的是 Office 即点即用,请参阅 修复 Office 应用程序

更多信息

如果在安装、启用或连接 Outlook Microsoft Dynamics CRM时仍遇到Microsoft Dynamics CRM Online问题,请运行Microsoft 支持部门和恢复助手