在 适用于手机的 Microsoft Dynamics 365 和平板电脑中找不到角色错误消息的任何应用

本文提供了使用 适用于手机的 Microsoft Dynamics 365 和平板电脑时发生的错误的解决方案。

适用于: Microsoft Dynamics 365
原始 KB 数: 4486472

现象

将 Dynamics 365 用于手机和平板电脑时,会收到以下消息:

“找不到你的角色的任何应用。 若要检查最近添加的应用,请选择“刷新”。
如果找不到应用,请更改搜索条件,然后重试。

原因

原因 1:没有任何 Dynamics 365 安全角色提供对任何统一接口应用的访问权限。

原因 2:没有具有模型驱动应用权限的 Dynamics 365 安全角色。

解决方法

解决方法 1:验证用户是否有权访问至少一个统一接口应用。

  1. 以具有系统管理员安全角色的用户身份访问 Dynamics 365 Web 应用程序。

  2. 导航到“设置”,然后选择我的应用

    注意

    如果未看到我的应用,可以将 /apps 添加到 URL 的末尾:https://<your_organization_URL>/apps
    示例: https://contoso.crm.dynamics.com/apps

  3. 找到希望用户使用的应用,然后选择省略号(...)选项,然后选择“ 管理角色”。

    注意

    ... 选项仅显示在统一接口类型的应用上,这是唯一支持用于适用于手机和平板电脑的 Dynamics 365 的应用。 如果还没有统一接口应用,可以使用 “创建新应用 ”选项。

  4. 将显示 Dynamics 365 安全角色的列表。 验证是否选择了至少一个分配给用户的角色,然后选择“ 保存”。

有关详细信息,请参阅 使用安全角色管理对应用的访问。

解决方法 2:验证用户的角色是否包含模型驱动应用权限

  1. 以具有系统管理员安全角色的用户身份访问 Dynamics 365 Web 应用程序。
  2. 导航到“设置”,选择“安全性,然后选择“安全角色”。
  3. 打开分配给用户的角色。
  4. 选择“自定义”选项卡,找到模型驱动的应用权限。 验证角色是否至少 包含此权限的读取 访问权限。
  5. 选择保存并关闭