无法在 Microsoft Dynamics 365 中使用 NoRecipientMatch 同步错误创建电子邮件
适用于: Microsoft Dynamics 365
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本文针对由于 NoRecipientMatch 同步错误而无法在 Microsoft Dynamics 365 中创建电子邮件的问题提供解决方法。
现象
查看通过 Microsoft Dynamics 365 分析的自动升级的电子邮件时,可能会收到一封无法使用 NoRecipientMatch 同步错误或错误代码 -2147218683创建的电子邮件。
原因
评估邮箱中的电子邮件时,Dynamics 365 会检查多个条件,以确定邮件是否应自动创建为 电子邮件活动。 NoRecipientMatch 错误可能因以下原因之一而发生:
电子邮件的 “收件人 ”或 “抄送 ”行上没有电子邮件地址是 Dynamics 365 中的用户或队列。
- 示例 A:你会收到电子邮件,因为它已发送到通讯组,并且你是该通讯组的成员。 存储在 Dynamics 365 中的电子邮件地址实际上不在电子邮件的 “收件人 ”或 “抄送 ”行中。
- 示例 B:对于同一邮箱,有多个电子邮件地址(例如
John@contoso.com
,和John.David@contoso.com
),但电子邮件的 “收件人 ”或 “抄送 ”行的电子邮件地址与 Dynamics 365 中用户记录中存储的任何电子邮件地址都不匹配。
电子邮件的“收件人”或“抄送”行上有用户或队列,但存在以下条件:
用户或队列使用的电子邮件地址存在于 Dynamics 365 中的其他记录上。 例如,用户具有
John@contoso.com
电子邮件地址,但该电子邮件地址也存在于另一个已启用电子邮件的实体(例如用户、队列、联系人、潜在顾客或帐户)的电子邮件地址字段上。如果找到多个匹配项,你的组织将电子邮件地址值保留为未解析。
上述两个条件的组合会导致电子邮件无法解析为用户或队列记录。
用户或队列的电子邮件地址位于 电子邮件的密件抄送 行上。
例如,由于电子邮件地址位于电子邮件的密件抄送行上,因此你会收到电子邮件。 除非 Dynamics 365 中的个人选项配置为跟踪 所有电子邮件,否则不会跟踪电子邮件。
除非电子邮件的“收件人”或“抄送”行的电子邮件地址与 Dynamics 365 中存储的电子邮件地址匹配,或者 Dynamics 365 中的个人选项配置为跟踪所有电子邮件,否则不会跟踪电子邮件。
表中没有接收电子邮件的用户或队列邮箱的行
EmailSearchBase
。查找匹配的用户或队列记录时,Dynamics 365 查询名为
EmailSearchBase
的表。 此表应自动为每个已启用电子邮件的记录的电子邮件地址(包括用户和队列)创建一行。 在极少数情况下,行可能缺失,这会导致 Dynamics 365 在查询此表时找不到匹配行,而用户或电子邮件上的队列。可以打开 Web 浏览器,并使用 Dynamics 365 Web API 验证是否存在用于接收电子邮件的用户或队列电子邮件地址的行。 使用以下语法:
https://<Your Organization URL>/api/data/v9.1/emailsearches?$filter=emailaddress eq '<email address of user or queue>'
例如,
https://contoso.crm.dynamics.com/api/data/v9.1/emailsearches?$filter=emailaddress eq 'John@contoso.com'
。如果未返回任何记录,则表示表中该电子邮件地址
EmailSearchBase
不存在行。
解决方法
查看电子邮件的特征,以及你在个人选项中为电子邮件跟踪配置的选项。
备注
若要管理安全角色和邮箱设置,需要以具有“系统管理员”角色的用户身份登录到 Dynamics 365 组织。
验证 Dynamics 365 中存储的电子邮件地址:
导航到“设置>电子邮件配置”,然后选择“邮箱”。
打开邮箱记录并验证电子邮件的 “收件人 ”或 “抄送 ”行的电子邮件地址是否与邮箱记录中找到的电子邮件地址匹配。
备注
如果邮箱有多个电子邮件地址,请选择有关查找的内容,并将另一个电子邮件地址添加到用户记录中的其他电子邮件地址字段之一。
如果多个记录(例如,其他用户、队列、潜在顾客、帐户和联系人)上存在用户或队列的电子邮件地址,请从其他记录中删除电子邮件地址,或者将“设置为”、“抄送”、“密件抄送”字段作为未解析的值(如果在“传入电子邮件”设置中找到多个匹配项,则将其更改为“否”。 可以通过导航到“设置>电子邮件配置>电子邮件配置设置”找到此设置。 在“设置电子邮件”窗体选项部分中,在“传入电子邮件”中找到多个匹配项时,找到名为“设置为”、“抄送”、“密件抄送”字段作为未解析的值的设置。
查看或更改电子邮件跟踪设置:
通过选择设置(右上角的齿轮图标),然后选择 “选项”,访问 Dynamics 365 中的个人选项。
选择电子邮件选项卡。
在 “选择要跟踪Microsoft Dynamics 365”部分中的电子邮件下,找到“ 跟踪 ”设置。
根据需要调整选项,以控制应在 Dynamics 365 中自动跟踪哪些电子邮件。
例如,如果要为接收的电子邮件自动创建电子邮件活动,而不考虑 Dynamics 365 中的发件人,请选择“所有电子邮件”选项。
有关电子邮件关联的详细信息,请参阅 电子邮件筛选和关联。
如果在使用原因 4 中的步骤时未找到任何记录,请执行以下步骤:
- 在 Dynamics 365 中打开用户或队列记录。
- 将电子邮件地址值更改为其他内容,然后选择“ 保存”。
- 将电子邮件地址值更改回正确的值,然后选择“ 保存”。 然后,将重新创建缺少的行。