本文提供了Microsoft Dynamics 365 邮箱记录中记录的错误的解决方法。
适用于: Microsoft Dynamics 365
原始 KB 数: 4340389
现象
以下错误记录在 Dynamics 365 邮箱记录的“警报 ”部分中:
通过邮箱邮箱名称>接收电子邮件时出现常规邮箱<访问错误。 Microsoft Exchange Online 通知关联的电子邮件服务器配置文件的所有者。 系统稍后将尝试再次接收电子邮件。
电子邮件服务器错误代码: Exchange 服务器返回 ErrorMailboxStoreUnavailable 异常。
原因
在 Dynamics 365 中使用 服务器端同步 功能与 Microsoft Exchange 集成时,可能会发出警报。 当 Dynamics 365 尝试使用 Exchange Web 服务(EWS)检索邮箱的信息时,Exchange 可能会使用 ErrorMailboxStoreUnavailable 做出响应。 如 ResponseCode 中所述,响应指示 Exchange 无法处理请求,因为邮箱当时不可用。
此错误指示发生了以下错误条件之一。
- 邮箱存储已损坏。
- 邮箱存储正在停止。
- 邮箱存储处于脱机状态。
- 尝试访问邮箱存储时发生网络错误。
- 邮箱存储已重载,不能再接受任何连接。
- 邮箱存储已暂停。
解决方法
如果此错误间歇性出现,但传入和传出电子邮件正在成功处理,则可以忽略此错误。 Dynamics 365 将再次尝试访问邮箱。
如果错误仍然存在,请确保 Exchange 邮箱可访问。 如果使用 Exchange Online,请以 Microsoft 365 管理员身份检查 服务运行状况仪表板 ,以确保 Exchange Online 没有报告的服务运行状况问题。
详细信息
若要在系统设置中禁用服务器端同步的警告级别警报,请执行以下操作:
- 以具有系统管理员角色的用户身份登录到 Dynamics 365 Web 应用程序。
- 导航到 “设置” ,然后选择“ 电子邮件配置”。
- 选择电子邮件配置设置。 默认情况下应选择“电子邮件”选项卡。
- 在 “配置警报 ”部分中,禁用 “警告 ”选项,然后选择“ 确定”。