Salesforce CRM 用户无法在 Sales 应用中查看、编辑或保存数据

本文可帮助你解决用户无法在 Sales 应用中查看、编辑或保存数据的问题。

谁受影响?

要求类型 Description
客户端应用 Outlook 中的销售应用
平台 Web 和桌面客户端
操作系统 Windows 和 Mac
部署 用户管理和管理员管理
CRM Salesforce
用户 无权查看销售应用窗体中添加的字段的用户无法保存、编辑或查看窗体

现象

当用户在 Outlook 中打开 Sales 应用时,将显示以下错误消息:

出现错误。

选择“ 显示详细信息”时,会看到“SFTypeNotSupported”或“SFInvalidField”错误代码。

显示用户在 CRM 中无权查看、创建或编辑对象时发生的错误的屏幕截图。

原因

用户无权在 Salesforce CRM 中查看、创建或编辑对象。 因此,Sales 应用无法在配置中按预期引用该对象。

对象必须至少具有要在 Sales 应用中显示的读取权限。 例如,如果用户没有联系人实体的读取权限,联系人将不会显示在 Sales 应用中。

解决方法

若要解决此问题,请在 Salesforce 中更新用户配置文件权限。

  1. 以管理员身份登录到 Salesforce CRM。

  2. 转到>

  3. 查找遇到该问题的用户,并选择分配给用户的配置文件。 根据配置文件类型执行以下步骤:

    • 如果配置文件不是自定义配置文件,请将其更改为具有正确权限的配置文件。
    • 如果配置文件正确且是自定义配置文件,请选择“ 编辑”。 然后,在 “标准对象权限 ”部分中,提供所需的权限。
  4. 保存更改。

    注意

    • 更新配置文件中的权限可能会影响分配给同一配置文件的其他用户。
    • 用户必须有权从 Microsoft Teams 中的管理员设置访问添加到 Sales 应用的所有对象。

详细信息

如果你的问题仍未解决,请转到 Microsoft 365 Copilot 中的销售部门 - Microsoft社区中心 与我们的专家联系。

第三方信息免责声明

本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。