使用域凭据SQL Server服务无法启动

本文讨论当启动帐户没有所需权限时,SQL Server无法启动的问题。

原始产品版本:SQL Server
原始 KB 编号: 3006856

症状

尝试启动或重启SQL Server服务时,它无法执行此操作,并且以下消息记录在SQL Server错误日志中:

<Time stamp> spid9s Error: 17182, Severity: 16, State: 1.

<Time stamp> spid9s TDSSNIClient initialization failed with error 0xffffffff, status code 0x80. Reason: Unable to initialize SSL support.

<Time stamp> spid9s Error: 17182, Severity: 16, State: 1.

<Time stamp> spid9s TDSSNIClient initialization failed with error 0xffffffff, status code 0x1. Reason: Initialization failed with an infrastructure error. Check for previous errors.

<Time stamp> spid9s Error: 17826, Severity: 18, State: 3. Time stamp spid9s Could not start the network library because of an internal error in the network library. To determine the cause, review the errors immediately preceding this one in the error log.

<Time stamp> spid9s Error: 17120, Severity: 16, State: 1. Time stamp spid9s SQL Server could not spawn FRunCommunicationsManager thread. Check the SQL Server error log and the Windows event logs for information about possible related problems.

注意

此问题仅在域帐户下运行的 SQL Server 实例上发生。

原因

出现此问题的原因是缺少向 SQL 服务帐户授予的常见权限。 必须存在的SQL Server启动帐户的用户权限如下所示:

  • (SeIncreaseQuotaPrivilege) 调整进程的内存配额

  • 绕过遍历检查 (SeChangeNotifyPrivilege) 。

  • 以服务 (SeServiceLogonRight) 登录。

  • (SeAssignPrimaryTokenPrivilege) 替换进程级令牌

有关详细信息,请参阅 服务权限

解决方案

若要解决此问题,请使用本地安全策略 MMC 管理单元中的“用户权限分配”窗格向 SQL 服务域帐户授予缺少的权限。