登入的用戶升級至 Microsoft Dynamics CRM 2011 之後沒有適當的安全性許可權錯誤
本文提供解決無法升級至 Dynamics CRM 2011 Microsoft因為登入的使用者沒有適當的安全性許可權,無法檢視這些記錄或執行此錯誤的特定動作 。
適用於: Microsoft Dynamics CRM 2011
原始 KB 編號: 953962
徵兆
升級至 Microsoft Dynamics CRM 2011 之後,嘗試 Microsoft在 Dynamics CRM 中執行動作時,使用者可能會遇到下列錯誤:
登入的用戶沒有適當的安全性許可權可檢視這些記錄或執行特定動作。
如果已啟用 Microsoft Dynamics CRM 平台追蹤,平台追蹤會包含下列錯誤資訊:
MSCRM 錯誤報告:
--------------------------------------------------------------------------------------------------------
錯誤:伺服器無法處理要求。
錯誤號碼:0x80040220
錯誤訊息:SecLib::CrmCheckPrivilege 失敗。 傳回的 hr = -2147220960 userId: <ID> 和 PrivilegeId: <ID>
注意
在此範例資訊中,UserId 值和 PrivilegeId 值是實際值的佔位符。
原因
當您升級至 Microsoft Dynamics CRM 2011 時,自定義安全性角色不會自動授與所有新功能的許可權。 只有現成角色會被授與默認許可權。
如果使用者的角色未獲授與執行動作所需的許可權,也可能會發生此問題。 如果下列其中一個條件成立,就可能發生這種情況:
- 角色是從頭開始建立的。
- 角色是從標準角色複製而來。 然後,角色已廣泛編輯。
解決方法
若要解決此問題,請遵循下列步驟。
注意
這些步驟會要求您從 dynamics CRM 平台追蹤Microsoft取得資訊。
在Microsoft Dynamics CRM 平台追蹤中顯示的錯誤資訊中,找出 PrivilegeId 值。
執行使用 PrivilegeId 值的 SQL 查詢來判斷遺漏的許可權。 例如,針對 OrganizationName 執行類似下列專案的 SQL 查詢_MSCRM資料庫:
select Name, * from PrivilegeBase where PrivilegeId = 'a8ecac53-09e8-4a13-b598-8d8c87bc3d33'
若要將遺失的許可權授與使用者,請遵循下列步驟:
- 開始Microsoft Dynamics CRM 2011。
- 選取 [設定],選取 [設定] 下的 [系統管理],然後選取 [安全性角色]。
- 按兩下指派給使用者的角色。
- 將遺漏的許可權授與使用者的角色。 例如,若要將 prvReadLead 許可權授與使用者的角色,請選取 [核心記錄] 索引標籤,然後在 [潛在客戶] 數據列上,選取適當的 [讀取] 許可權。
- 選取儲存後關閉。