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使用 Dynamics 365 App for Outlook Microsoft 時,無法連線到 Exchange 訊息

本文提供您在使用 Dynamics 365 App for Outlook Microsoft時無法連線到 Exchange 訊息的問題解決方式。

適用於: Microsoft Dynamics 365 Customer Engagement Online
原始 KB 編號: 4534356

徵兆

使用 Microsoft Dynamics 365 App for Outlook 時,您會看到下列訊息:

「無法連線到 Exchange」。

其餘的應用程式可能會成功載入,但追蹤專案和使用Set Regarding 的能力可能會遺失。

原因

這通常會在使用 Microsoft Exchange 內部部署信箱時發生,可能是因為下列其中一個原因所造成:

原因 1: Exchange 中未啟用 OAuth 驗證。
原因 2: Exchange 所使用的驗證憑證發生問題。

解決方案 1:確認 Exchange 中已啟用 OAuth 驗證

  1. 在 Exchange 伺服器上,開啟 Exchange 管理命令介面

  2. 執行以下命令:

    Get-WebServicesVirtualDirectory | FL server,*auth
    
  3. 確認傳回的結果顯示 OAuthAuthentication 已設定為 True

  4. 如果 OAuthAuthentication 設定為 False,則必須執行下列命令:

    Set-WebServicesVirtualDirectory -Identity "EWS (Default Web Site)" -OAuthAuthentication $true
    

    識別值是可在 Exchange 系統管理中心找到的虛擬目錄名稱,方法是選取 伺服器 ,然後選取 虛擬目錄 ,或執行下列命令並檢閱傳回的 Name 值:

    Get-WebServicesVirtualDirectory | FL
    

    如需此命令的詳細資訊,請參閱 Set-WebServicesVirtualDirectory

    如需允許 Outlook 載入巨集提出異步 Exchange Web 服務 (EWS) 要求之驗證需求的詳細資訊,請參閱 makeEwsRequestAsync 的驗證和許可權考慮。

  5. 執行以下命令:

    Get-OrganizationConfig | FL OAuth2ClientProfileEnabled
    

    如果傳回的值為 False,請執行下列命令:

    Set-OrganizationConfig -OAuth2ClientProfileEnabled:$True
    
  6. 此外,請確認您的 Exchange 版本有無法在 Exchange Server 2016 和 Exchange Server 2013 中透過 makeEwsRequestAsync 從 Outlook/OWA 載入巨集存取 EWS 中所述的更新

解決方案 2:驗證 Exchange 憑證

  1. 在 Exchange 伺服器上,開啟 Exchange 管理命令介面

  2. 執行以下命令:

    Get-AuthConfig | FL

  3. 確認結果顯示 IsValidTrue

  4. 複製 CurrentCertificateThumbprint 傳回的值,並在下列命令中使用:

    Get-ExchangeCertificate -Thumbprint <CurrentCertificateThumbprint Value>| FL
    
  5. 確認結果顯示下列內容:

    狀態 = 有效

    目前的日期在 NotAfter 和 NotBefore 日期內,表示憑證未過期。

    如果先前的命令未成功擷取憑證,這表示憑證設定可能會要求您建立及設定新憑證的問題。 以下是一些資源,其中包含建立和設定新憑證的步驟:

如果遵循上述步驟之後需要進行任何變更,請關閉並重新開啟 Outlook,以查看問題是否已解決。 如果問題持續發生,且您的 Microsoft Exchange 系統管理員已確認 OAuth 已啟用且憑證有效,可能需要連絡 Microsoft 支援服務。