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同步處理約會、聯繫人和工作時發生內部Microsoft Dynamics 365 錯誤

本文提供在 Microsoft Dynamics 365 中選取 信箱記錄上 [測試及啟用信箱 ] 時所發生的 “UserPrivilegeError” 解決方案。

適用於: Microsoft Dynamics 365
原始 KB 編號: 4346733

徵兆

當您在 Dynamics 365 的信箱記錄上選取 [ 測試及啟用信箱 ] 時,[ 約會]、[連絡人] 和 [工作狀態 ] 字段會顯示為 [失敗]。 下列訊息會記錄在 [ 警示 ] 區段中:

同步處理信箱 <信箱名稱>的約會、聯繫人和工作時,發生內部Microsoft Dynamics 365 錯誤。 信箱未同步處理。 並且已通知相關電子郵件伺服器設定檔 <Email Server Profile Name> 的負責人。
電子郵件伺服器錯誤碼: UserPrivilegeError

原因

含有 「UserPrivilegeError」 電子郵件伺服器錯誤碼的錯誤訊息表示擁有此信箱的使用者沒有足夠的許可權。 如需必要許可權清單,請參閱使用伺服器端同步處理時發生 PrivilegeDenied 錯誤。

重要

確認信箱記錄的擁有者符合使用者。 例如,如果信箱屬於Paul Cannon,請確定 記錄中的擁有者 值也是Paul Cannon。 如果顯示不同的使用者,該使用者可能無法存取 Paul Cannon 的信箱。

解決方法

若要修正此問題,請依照下列步驟操作:

  1. 以具有「系統管理員」角色的使用者身分開啟 Dynamics 365 中的信箱記錄。

    提示

    警示包含信箱記錄的連結。

  2. 確認 信箱表單中的 [擁有者 ] 字段已填入使用者的名稱。 如果列出其他使用者,請將它變更為用戶的名稱。

  3. 選取 [ 擁有者 ] 字段中的連結,以開啟該擁有者的用戶記錄。

  4. 選取 [ 管理角色 ] 以查看指派給此用戶的安全性角色。

  5. 瀏覽至 設定>安全性>安全性角色

  6. 開啟步驟 4 中找到的角色。 如需必要許可權的清單,請參閱 使用伺服器端同步 處理時發生 PrivilegeDenied 錯誤,然後確認使用者的安全性角色包含這些許可權。

  7. 確認使用者是信箱記錄的擁有者,且其安全性角色包含必要許可權之後,請再次選取 信箱記錄中的 [測試及啟用信箱 ]。 如果測試未產生成功,請檢閱 [警示] 區段中出現的訊息以取得進一步的詳細數據。