在 Dynamics 365 中測試和啟用信箱時,「無法判斷信箱位置」錯誤
本文提供當您嘗試在 Dynamics 365 Microsoft 中測試及啟用信箱時所發生的錯誤解決方案。
適用於: Microsoft Dynamics 365
原始 KB 編號: 4513810
徵兆
當您嘗試在 Dynamics 365 中測試並啟用信箱 時,測試結果區段會顯示 [失敗],並記錄下列其中一個警示:
-
傳送電子郵件訊息「您的信箱現在已連線至 Dynamics 365」時,無法判斷信箱位置。 信箱 <Mailbox Name> 未同步處理。 並且已通知相關電子郵件伺服器設定檔 <Email Server Profile Name> 的負責人。
-
無法判斷信箱 <信箱名稱> 的位置,而無法接收電子郵件。 並且已通知相關電子郵件伺服器設定檔 <Email Server Profile Name> 的負責人。 系統稍後會嘗試再次接收電子郵件。
原因
聯機到 Exchange 內部部署,且 Dynamics 365 中的電子郵件伺服器設定檔記錄設定 為 [自動探索伺服器位置 ] 設定為 [是] 時,可能會發生警示。 啟用此選項時,您不需要提供 Exchange Web 服務 (EWS) URL。 相反地,Dynamics 365 會嘗試使用 適用於 Exchange 的自動探索來擷取正確的位置。 如果自動探索服務發生問題,或未正確設定,可能會發生警示。
解決方法
若要解決此問題,您可以修正 Exchange 的自動探索問題,或將 [自動探索伺服器位置] 設定變更為 [否],並提供 EWS URL。
請遵循下列步驟來變更 [自動探索伺服器位置 ] 設定:
以具有「系統管理員」安全性角色的使用者身分登入 Dynamics 365 Web 應用程式。
流覽至 [設定>電子郵件設定>電子郵件伺服器設置檔]。
開啟 Exchange 內部部署設定的電子郵件伺服器設定檔記錄。
將 [ 自動探索伺服器位置] 設定變更為 [否]。
在 [傳入伺服器位置] 和 [傳出伺服器位置] 字段中輸入您的 EWS URL。 例如:
https://mail.yourdomain.com/EWS/Exchange.asmx
。選取儲存。