分享方式:


UnknownIncomingEmailIntegrationError -2147220891或80040265會出現在 Microsoft Dynamics 365 的信箱警示中

本文提供 dynamics 365 Microsoft 中信箱警示內發生之錯誤的解決方案。

適用於: Microsoft Dynamics 365
原始 KB 編號: 4466423

徵兆

在 Dynamics 365 中檢視信箱記錄內的警示區段,您會看到下列其中一則訊息:

  • 「透過信箱「信箱名稱>」<接收電子郵件時發生未知的錯誤。 已通知相關聯電子郵件伺服器配置檔配置檔 <名稱> 的擁有者。 系統稍後會嘗試再次接收電子郵件。

    電子郵件伺服器錯誤碼: Exchange Server 傳回 UnknownIncomingEmailIntegrationError -2147220891例外狀況。」

  • 「同步處理信箱「信箱名稱>」<的約會、聯繫人和工作時發生內部Microsoft Dynamics 365 錯誤。 已通知相關聯電子郵件伺服器配置檔配置檔 <名稱> 的擁有者。 系統稍後會再試一次。

    電子郵件伺服器錯誤碼: Crm.80040265.ISV 程式代碼中止作業。」

原因

錯誤碼80040265或 -2147220891表示 IsvAborted 錯誤。

如果您在 [徵兆] 區段中看到第一則訊息,通常是由建立電子郵件記錄時執行的工作流程或自定義外掛程式所造成。

如果您在 [徵兆] 區段中看到第二則訊息,通常是由建立約會、聯繫人或工作記錄時執行的工作流程或自定義外掛程式所造成。

解決方法

在建立錯誤中所提及的記錄類型(電子郵件、約會、聯繫人或工作)時,檢查是否有任何自定義外掛程式或工作流程同步執行。 如果外掛程式或工作流程在記錄建立期間造成錯誤,伺服器端同步處理就無法成功建立記錄。 下列步驟可協助您識別組織中是否有在建立電子郵件期間執行的任何工作流程或外掛程式。 將實體取代為適當的記錄類型,將約會和工作等其他實體使用相同的步驟。

工作流程

  1. 在 Dynamics 365 Web 應用程式中,流覽至 [ 設定],然後選取 [ 行程]。

  2. 將檢視變更為 [已啟動的進程]。

  3. 在 [主要實體] 數據行上排序,並尋找 [電子郵件] 做為主要實體和工作流程做為類別的任何數據列。

    相反地,您可以使用方格中的篩選選項來篩選 Category = WorkflowPrimary Entity = Email

  4. 開啟您發現符合上述準則的每個工作流程(如果有的話)。

  5. 如果選取 [建立記錄] 選項時啟動選項,且未選取 [在背景中執行此工作流程] 選項 (建議) 選項,則此工作流程可能是原因。

  6. 選取頁面左側的 [ 處理會話 ] 區段,並尋找與未成功建立之電子郵件相關的任何失敗。

外掛程式

  1. 在 Dynamics 365 Web 應用程式中,流覽至 [設定>自定義],然後選取 [自定義系統]。
  2. 選取 [Sdk 訊息處理步驟]。
  3. 排序主要物件類型代碼 (SdkMessage Filter) 數據行,並尋找電子郵件實體的任何數據列
  4. 如果這些數據列中的執行 模式 設定為 [同步],它可能會干擾電子郵件建立。

如果您能夠一致地重現問題,您可以嘗試暫時停用工作流程或外掛程式,以判斷工作流程或外掛程式是否為問題的原因。