針對 Azure 自動化帳戶問題進行疑難排解

本文討論當您使用 Azure 自動化帳戶時可能會遇到問題的解決方案。 如需自動化帳戶的一般資訊,請參閱 Azure 自動化帳戶驗證概觀

案例:當 GUID 用作帳戶名稱使用時,無法建立自動化帳戶

問題

當您建立使用 GUID 作為帳戶名稱的自動化帳戶時,您會遇到錯誤。

原因

accountid 是區域中所有自動化帳戶的唯一識別碼,而當帳戶名稱是 GUID 時,我們會將自動化帳戶識別碼和名稱保留為 GUID。 在此案例中,當您建立新的自動化帳戶,並指定 GUID (作為帳戶名稱) 時,如果名稱與任何現有的自動化帳戶識別碼發生衝突,就會發生錯誤。

例如,當您嘗試建立名稱為 8a2f48c1-9e99-472c-be1b-dcc11429c9ff 的自動化帳戶時,如果該區域中的所有自動化帳戶已有自動化帳戶識別碼,則帳戶建立將會失敗,您會看到下列錯誤:

   {

   "code": "BadRequest",

   "message": Automation account already exists with this account id. AccountId: 8a2f48c1-9e99-472c-be1b-dcc11429c9ff. 

   }

解決方法

確保您建立具有新名稱的自動化帳戶。

案例:無法為訂用帳戶註冊自動化資源提供者

問題

當您使用管理功能時,例如更新管理,在您的自動化帳戶中遇到下列錯誤:

Error details: Unable to register Automation Resource Provider for subscriptions:

原因

自動化資源提供者未在訂用帳戶中註冊。

解決方案

若要註冊自動化資源提供者,請在 Azure 入口網站中執行下列步驟:

  1. 在瀏覽器中,移至 Azure 入口網站

  2. 移至 [我的訂用帳戶],然後選取訂用帳戶。

  3. 在 [設定] 下,選取 [資源提供者]。

  4. 從資源提供者清單中,確認已註冊 Microsoft.Automation 資源提供者。

  5. 如果未列出提供者,請依照解決資源提供者註冊的錯誤中所述進行註冊。

後續步驟

如果本文無法解決您的問題,請嘗試下列其中一個管道以取得其他支援:

  • 透過 Azure 論壇獲得由 Azure 專家所提供的解答。
  • @AzureSupport 交流。 這是官方 Microsoft Azure 帳戶,可將 Azure 社群連結到正確的資源:解答、支援和專家。
  • 提出 Azure 支援事件。 請移至 Azure 支援網站,然後選取 [取得支援]。