New-MigrationEndpoint在 Exchange Online 中傳回錯誤:信箱不支援 MAPI 提供者

原始 KB 編號: 4052729

徵狀

當您執行 New-MigrationEndpoint Cmdlet 以在 Microsoft Exchange Online 中建立移轉端點的 PublicFolder 或 PublicFolderToGroups 類型時,您會收到下列錯誤訊息:

伺服器ServerName> 上 < 版本 < 為VersionNumber> 的信箱不支援 MAPI 提供者。

當您執行 New-MigrationEndpoint Cmdlet 時的錯誤資訊螢幕擷取畫面。

原因

發生此錯誤是因為下列信箱不在相同的伺服器上:

  • 主要階層公用資料夾信箱。
  • 名為 SystemMailbox{MailboxID} 的組織信箱。 (這是一種仲裁 mailbox.)

解決方案

若要解決此問題,請確定裝載這兩個信箱的資料庫位於相同的伺服器上。 如果要執行這項操作,請依照下列步驟執行:

  1. 執行下列其中一個 Cmdlet 選項,找出裝載主要階層公用資料夾信箱的資料庫:

    選項 1

    Get-Mailbox -PublicFolder | ?{$_.IsRootPublicFolderMailbox -eq $true} | ft name,database
    Get-MailboxDatabaseCopyStatus <database returned from the first cmdlet>
    

    選項 2

    Get-MailboxDatabase (Get-Mailbox -PublicFolder | ?{$_.IsRootPublicFolderMailbox -eq $true}).database | Get-MailboxDatabaseCopyStatus
    
  2. 執行下列其中一個 Cmdlet 選項,找出裝載主要階層公用資料夾信箱的資料庫:

    選項 1

    Get-Mailbox -Arbitration | ?{$_.name -like "SystemMailbox{MailboxID}"} | ft database
    Get-MailboxDatabaseCopyStatus <database returned from the first cmdlet>
    

    選項 2

    Get-MailboxDatabase (Get-Mailbox -Arbitration | ?{$_.name -like "SystemMailbox{MailboxID}"}).database | Get-MailboxDatabaseCopyStatus
    
  3. 如果裝載主要階層公用資料夾信箱和仲裁信箱的資料庫在同一部伺服器上有複本,請在同一部伺服器上啟用這兩個資料庫複本。

    否則,請移動仲裁信箱或主要階層公用資料夾信箱,讓這兩個信箱位於相同的伺服器上。