Microsoft Dynamics CRM for Phone 和 Tablets 無法連線到 Dynamics CRM 組織,因為 TokenLifetime 的長度
本文提供Microsoft Dynamics CRM for Phone 和 Tablets 因屬性長度 TokenLifetime
而無法連線到 Dynamics CRM 組織的問題。
適用於: Microsoft Dynamics CRM 2013、Microsoft Dynamics CRM 2013 Service Pack 1
原始 KB 編號: 3034570
徵兆
嘗試在任何 Microsoft Dynamics CRM 行動用戶端應用程式中設定 Microsoft Dynamics CRM 組織時,驗證會進入永不結束的迴圈,其中應用程式似乎嘗試執行某些驗證,但未完成。
原因
大於信賴憑證者 AD FS 中屬性的預設值 TokenLifetime
,可能會導致此驗證迴圈。
解決方法
的建議值 TokenLifetime
應該設定為預設值 0,這表示600分鐘或10小時。 請改用同盟服務中的 SSOLifetime 選項,以防止使用者在這些Microsoft Dynamics CRM 行動應用程式中經常引進其認證。 SSOLifetime 的預設值為 480 分鐘或 8 小時。
其他相關資訊
如何變更 ADFS 的 SSO Lifetime
屬性,請參閱 Set-ADFSProperties。
如何透過PowerShell變更 TokenLifetime
ADFS信賴憑證者的屬性,請參閱 宣告型驗證和安全性令牌到期。