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使用 Gmail 設定伺服器端同步處理時,無法傳送或接收電子郵件

本文提供使用 Gmail 設定伺服器端同步處理時所發生的錯誤解決方案。

適用於: Microsoft Dynamics CRM 2013、Microsoft Dynamics CRM 2015、Microsoft Dynamics CRM 2016、Microsoft Dynamics CRM 2016 Service Pack 1
原始 KB 編號: 3185281

徵兆

如果 Microsoft Dynamics CRM 設定為使用伺服器端同步處理與 Gmail,您可能會收到下列其中一個錯誤訊息:

無法接收信箱 <Mailbox Name> 的電子郵件。 請確定信箱中已指定正確的認證,並且擁有足夠的權限可以接收電子郵件。 然後,啟用信箱進行電子郵件處理。

傳送電子郵件訊息「測試訊息」時,發生不明的錯誤。 信箱 <Mailbox Name> 未同步處理。 並且已通知相關電子郵件伺服器設定檔 <Email Server Profile Name> 的負責人。

原因

發生錯誤的原因如下:

  • 原因 1

    Microsoft Dynamics CRM 信箱記錄中的電子郵件地址、使用者名稱或密碼不正確。

  • 原因 2

    Microsoft Dynamics CRM 中的電子郵件伺服器配置檔記錄內未設定正確的埠。

  • 原因 3

    Gmail 信箱上未啟用 POP。

  • 原因 4

    Gmail 中的設定可防止伺服器端同步驗證至 Gmail 信箱。

解決方法

  • 解決方法 1

    確認 Dynamics CRM 中信箱記錄 Microsoft 中 [電子郵件位址]、[使用者名稱] 和 [密碼] 字段的值。

  • 解決方法 2

    開啟 [電子郵件伺服器配置檔],然後選取 [ 進階]。 將 [連入埠] 設定為 995,並將 [傳出埠] 設定為 587。

  • 解決方法 3

    遵循 Gmail 指示來 啟用 POP

  • 解決方案 4

    請檢查您的 Gmail 信箱,以取得有關封鎖登入嘗試的電子郵件。 訊息會包含如何解除封鎖存取的步驟。 遵循步驟之後,請再次嘗試在CRM中測試並啟用信箱。

如果問題仍然發生,請參閱 針對登入問題進行疑難解答,其中包括從應用程式啟用電子郵件存取所需的其他步驟。

其他相關資訊

警示的詳細資料區段可能包含下列文字:

「錯誤:System.Net.Mail.SmtpException:語法錯誤,無法辨識命令。 伺服器回應為:
at System.Net.Mail.SmtpConnection.ConnectAndHandshakeAsyncResult.End(IAsyncResult result)
at System.Net.Mail.SmtpClient.ConnectCallback(IAsyncResult result)”

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