設定 Microsoft Office Outlook Microsoft Dynamics CRM 時,檔案已存在錯誤
本文提供當您設定 Microsoft Dynamics CRM for Microsoft Office Outlook 時所發生之錯誤的解決方案。
適用於: Microsoft Dynamics CRM Online、Microsoft Dynamics CRM 2016、Microsoft Dynamics CRM 2015、Microsoft Dynamics CRM 2013、Microsoft適用於 Microsoft Office Outlook 的 CRM 用戶端
原始 KB 編號: 3183053
徵兆
嘗試設定 Microsoft Dynamics CRM for Microsoft Office Outlook 時,您會收到下列錯誤:
「與 Microsoft Dynamics CRM 伺服器通訊時發生問題。 伺服器可能無法使用。 請稍後再試一次。 如果問題仍然存在,請連絡您的系統管理員。
檔案已存在。 請嘗試使用不同的資料庫名稱。 [ 檔案名 = C:\Users\<USER>\AppData\Local\Microsoft\MSCRM\Client\MetadataCache-5243bc89-09f7-4d12-b578-8efd890f5d7c.sdf ]...”
原因
如果CRM實例已有先前組態的資料庫檔案存在,就可能發生此錯誤。
解決方法
選項 1 (CRM Online)
- 如果您使用CRM Online,您可以執行 Microsoft 支援服務和Recovery Assistant,以為您修正此問題。
- 選擇 [Dynamics CRM Online] 選項,然後選取 [我在安裝、聯機或啟用 Outlook 的 CRM 時發生問題] (Outlook Client)。
- 繼續執行精靈。 CRM 用於 Outlook 動作的 [移除快取檔案] 應該會出現,並移除錯誤中所參考的現有檔案。
- 再次執行 Microsoft Dynamics CRM 設定精靈。
選項 2 (手動)
如果您不是使用CRM Online或偏好手動修正問題,請完成下列步驟。
關閉 Outlook。
開啟 Windows 檔案總管並瀏覽至
<install directory>:\Users\<Your User>\AppData\Local\Microsoft\MSCRM\Client
。範例:
C:\Users\<username>\AppData\Local\Microsoft\MSCRM\Client
注意
AppData 資料夾預設為隱藏。 您可以變更 [檢視] 設定以顯示 [隱藏的專案],也可以將下列路徑複製並貼到資料夾路徑中:
%localappdata%\Microsoft\MSCRM\Client
刪除錯誤詳細數據中所參考的檔案。
再次執行 Microsoft Dynamics CRM 設定精靈。