無法在 Dynamics CRM Microsoft 中連線到自定義外掛程式所產生的遠端伺服器錯誤
本文提供在 Microsoft dynamics CRM 環境中部署自定義外掛程式時所發生的錯誤解決方案,該環境會執行 SOAP 動作以連線至外部位址或服務。
適用於: Microsoft Dynamics CRM 2011、Dynamics CRM 2013、Microsoft Dynamics CRM 2013 Service Pack 1、Dynamics CRM 2015
原始 KB 編號: 3080697
徵兆
請考慮下列案例:自定義外掛程式會部署在Microsoft Dynamics CRM 環境中,執行SOAP動作以連線到外部位址或服務。 如果外部通訊需要網路 Proxy,外掛程式可能會收到下列其中一個錯誤訊息:
無法連線到遠端伺服器
錯誤:未在自定義服務位址>接<聽無法接受訊息的端點。 這通常是因為位址或SOAP動作不正確所造成。 如需詳細資訊,請參閱 InnerException,如果有的話。
原因
Microsoft Dynamics CRM 應用程式伺服器位於網路 Proxy 後方,且外掛程式設定為在隔離模式 (沙箱) 中執行。 在此案例中,執行 Microsoft Dynamics CRM 沙盒服務的服務帳戶無法透過網路 Proxy 存取。
解決方法
使用下列步驟來設定 Microsoft Dynamics CRM 沙盒服務帳戶以使用網路 Proxy:
- 使用 Microsoft Dynamics CRM 沙盒服務帳戶登入 Microsoft Dynamics CRM 應用程式伺服器。
- 開啟 Internet Explorer。
- 流覽至 [工具>因特網選項>連線>LAN 設定]。
- 根據本機環境組態,更新 [使用自動設定腳本] 或 [Proxy 伺服器] 區段。
其他相關資訊
當外掛程式在隔離模式中執行時,Microsoft Dynamics CRM 沙盒服務帳戶會呼叫外部位址或服務。 此帳戶可以從裝載 Microsoft Dynamics CRM 沙盒服務的 Microsoft Dynamics CRM 伺服器存取外部服務。