Bookmarks - List
取得所有書籤。
GET https://management.azure.com/subscriptions/{subscriptionId}/resourceGroups/{resourceGroupName}/providers/Microsoft.OperationalInsights/workspaces/{workspaceName}/providers/Microsoft.SecurityInsights/bookmarks?api-version=2025-09-01
URI 參數
| 名稱 | 位於 | 必要 | 類型 | Description |
|---|---|---|---|---|
|
resource
|
path | True |
string minLength: 1maxLength: 90 |
資源群組的名稱。 名稱不區分大小寫。 |
|
subscription
|
path | True |
string (uuid) |
目標訂用帳戶的標識碼。 此值必須是 UUID。 |
|
workspace
|
path | True |
string minLength: 1maxLength: 90 pattern: ^[A-Za-z0-9][A-Za-z0-9-]+[A-Za-z0-9]$ |
工作區的名稱。 |
|
api-version
|
query | True |
string minLength: 1 |
用於此作業的 API 版本。 |
回應
| 名稱 | 類型 | Description |
|---|---|---|
| 200 OK |
確定,操作順利完成 |
|
| Other Status Codes |
描述作業失敗原因的錯誤回應。 |
安全性
azure_auth
Azure Active Directory OAuth2 流
類型:
oauth2
Flow:
implicit
授權 URL:
https://login.microsoftonline.com/common/oauth2/authorize
範圍
| 名稱 | Description |
|---|---|
| user_impersonation | 模擬您的用戶帳戶 |
範例
Get all bookmarks.
範例要求
GET https://management.azure.com/subscriptions/d0cfe6b2-9ac0-4464-9919-dccaee2e48c0/resourceGroups/myRg/providers/Microsoft.OperationalInsights/workspaces/myWorkspace/providers/Microsoft.SecurityInsights/bookmarks?api-version=2025-09-01
範例回覆
{
"value": [
{
"id": "/subscriptions/d0cfe6b2-9ac0-4464-9919-dccaee2e48c0/resourceGroups/myRg/providers/Microsoft.OperationalInsights/workspaces/myWorkspace/providers/Microsoft.SecurityInsights/bookmarks/73e01a99-5cd7-4139-a149-9f2736ff2ab5",
"name": "73e01a99-5cd7-4139-a149-9f2736ff2ab5",
"type": "Microsoft.SecurityInsights/bookmarks",
"etag": "\"0300bf09-0000-0000-0000-5c37296e0000\"",
"properties": {
"displayName": "My bookmark",
"createdBy": {
"objectId": "2046feea-040d-4a46-9e2b-91c2941bfa70",
"email": "john@contoso.com",
"name": "john doe"
},
"updatedBy": {
"objectId": "2046feea-040d-4a46-9e2b-91c2941bfa70",
"email": "john@contoso.com",
"name": "john doe"
},
"updated": "2019-01-01T13:15:30Z",
"created": "2019-01-01T13:15:30Z",
"notes": "Found a suspicious activity",
"labels": [
"Tag1",
"Tag2"
],
"query": "SecurityEvent | where TimeGenerated > ago(1d) and TimeGenerated < ago(2d)",
"queryResult": "Security Event query result",
"incidentInfo": {
"incidentId": "DDA55F97-170B-40B9-B8ED-CBFD05481E7D",
"severity": "Low",
"title": "New case 1",
"relationName": "4bb36b7b-26ff-4d1c-9cbe-0d8ab3da0018"
}
}
}
]
}
定義
| 名稱 | Description |
|---|---|
| Bookmark |
代表 Azure 安全性深入解析中的書籤。 |
|
Bookmark |
列出所有書籤。 |
|
Cloud |
錯誤回應結構。 |
|
Cloud |
錯誤詳細數據。 |
|
created |
建立資源的身分識別類型。 |
|
Incident |
描述書籤的相關事件資訊 |
|
Incident |
事件的嚴重性 |
|
system |
與建立和上次修改資源相關的元數據。 |
|
User |
做出某些動作的使用者資訊 |
Bookmark
代表 Azure 安全性深入解析中的書籤。
| 名稱 | 類型 | Description |
|---|---|---|
| etag |
string |
Azure 資源的 Etag |
| id |
string (arm-id) |
資源的完整資源標識碼。 例如 “/subscriptions/{subscriptionId}/resourceGroups/{resourceGroupName}/providers/{resourceProviderNamespace}/{resourceType}/{resourceName}” |
| name |
string |
資源的名稱 |
| properties.created |
string (date-time) |
書籤的建立時間 |
| properties.createdBy |
描述建立書籤的使用者 |
|
| properties.displayName |
string |
書籤的顯示名稱 |
| properties.eventTime |
string (date-time) |
書籤事件時間 |
| properties.incidentInfo |
描述與書籤相關的事件 |
|
| properties.labels |
string[] |
與此書籤相關的標籤清單 |
| properties.notes |
string |
書籤的註釋 |
| properties.query |
string |
書籤的查詢。 |
| properties.queryEndTime |
string (date-time) |
查詢的結束時間 |
| properties.queryResult |
string |
書籤的查詢結果。 |
| properties.queryStartTime |
string (date-time) |
查詢的開始時間 |
| properties.updated |
string (date-time) |
上次更新書籤的時間 |
| properties.updatedBy |
描述更新書籤的使用者 |
|
| systemData |
包含 createdBy 和 modifiedBy 資訊的 Azure Resource Manager 中繼資料。 |
|
| type |
string |
資源的類型。 例如「Microsoft.Compute/virtualMachines」或「Microsoft.Storage/storageAccounts」 |
BookmarkList
列出所有書籤。
| 名稱 | 類型 | Description |
|---|---|---|
| nextLink |
string |
URL 來擷取下一組案例。 |
| value |
Bookmark[] |
書籤陣列。 |
CloudError
錯誤回應結構。
| 名稱 | 類型 | Description |
|---|---|---|
| error |
錯誤資料 |
CloudErrorBody
錯誤詳細數據。
| 名稱 | 類型 | Description |
|---|---|---|
| code |
string |
錯誤的識別碼。 程序代碼是不變的,而且是要以程序設計方式取用。 |
| message |
string |
描述錯誤的訊息,適用於在使用者介面中顯示。 |
createdByType
建立資源的身分識別類型。
| 值 | Description |
|---|---|
| User | |
| Application | |
| ManagedIdentity | |
| Key |
IncidentInfo
描述書籤的相關事件資訊
| 名稱 | 類型 | Description |
|---|---|---|
| incidentId |
string |
事件識別碼 |
| relationName |
string |
關係名稱 |
| severity |
事件的嚴重性 |
|
| title |
string |
事件名稱 |
IncidentSeverity
事件的嚴重性
| 值 | Description |
|---|---|
| High |
高嚴重性 |
| Medium |
中等嚴重性 |
| Low |
低嚴重性 |
| Informational |
資訊嚴重性 |
systemData
與建立和上次修改資源相關的元數據。
| 名稱 | 類型 | Description |
|---|---|---|
| createdAt |
string (date-time) |
資源建立的時間戳(UTC)。 |
| createdBy |
string |
建立資源的身分識別。 |
| createdByType |
建立資源的身分識別類型。 |
|
| lastModifiedAt |
string (date-time) |
上次修改的資源時間戳 (UTC) |
| lastModifiedBy |
string |
上次修改資源的身分識別。 |
| lastModifiedByType |
上次修改資源的身分識別類型。 |
UserInfo
做出某些動作的使用者資訊
| 名稱 | 類型 | Description |
|---|---|---|
|
string |
使用者的電子郵件。 |
|
| name |
string |
用戶的名稱。 |
| objectId |
string (uuid) |
使用者的物件識別碼。 |