針對在 Azure 中重新開機或調整現有 Windows VM 大小的部署問題進行疑難排解

當您嘗試啟動已停止的 Azure 虛擬機器 (VM) ,或調整現有 Azure VM 的大小時,您遇到的常見錯誤是配置失敗。 當叢集或區域沒有可用的資源,或無法支援要求的 VM 大小時,就會產生此錯誤。

如果本文未解決您的 Azure 問題,請造訪 MSDN 和 Stack Overflow上的 Azure 論壇。 您可以在這些論壇張貼您的問題,或張貼到 Twitter 上的@AzureSupport。 您也可以提交Azure 支援要求。 若要提交支援要求,請在[Azure 支援] 頁面上,選取 [取得支援]

收集活動記錄

若要開始疑難排解,請收集活動記錄以識別與問題相關聯的錯誤。 下列連結包含程式的詳細資訊:

檢視部署作業

檢視活動記錄以管理 Azure 資源

問題:啟動已停止的 VM 時發生錯誤

您嘗試啟動已停止的 VM,但發生配置失敗。

原因

必須在裝載雲端服務的原始叢集嘗試啟動已停止 VM 的要求。 不過,叢集沒有可用空間可滿足要求。

解決方案

  • 停止可用性設定組中的所有 VM,然後重新開機每個 VM。

    1. 按一下資源群組>資源群組>資源>您的可用性設定組>虛擬機器>您的虛擬機器>停止
    2. 在所有 VM 停止之後,選取每個已停止的 VM,然後按一下 [啟動]。
  • 稍後再重試重新開機要求。

問題:調整現有 VM 的大小時發生錯誤

您嘗試調整現有 VM 的大小,但發生配置失敗。

原因

必須在裝載雲端服務的原始叢集嘗試調整 VM 大小的要求。 不過,叢集不支援要求的 VM 大小。

解決方案

  • 使用較小的 VM 大小重試要求。

  • 如果要求的 VM 大小無法變更:

    1. 停止可用性設定組中的所有 VM。

      • 按一下資源群組>資源群組>資源>您的可用性設定組>虛擬機器>您的虛擬機器>停止
    2. 所有 VM 停止之後,將所需的 VM 大小調整為較大的大小。

    3. 選取調整大小的 VM,然後按一下 [ 啟動],然後啟動每個已停止的 VM。

當您停止、啟動、重新開機或重新部署現有的 VM 時發生錯誤

當您嘗試停止、啟動、重新開機或重新部署現有的 VM 時,進程會失敗,而且您會收到「處理 VM 的網路設定檔時發生意外的錯誤。 請稍後重試」錯誤訊息。 發生此錯誤時,VM 會進入失敗狀態。

原因

如果配置或更新網路資源時發生問題,就會發生此問題。

解決方案

嘗試重新套用虛擬機器狀態。 此作業會重新執行 VM 布建,並協助解決當您執行先前的 VM 動作時,VM 布建失敗時所發生的 VM 狀態失敗。

  1. 流覽至卡在失敗狀態的 VM。
  2. 在 [ 說明]底下,選取 [ 重新部署 + 重新套用]
  3. 選取 [重新套用] 選項。

後續步驟

如果您在 Azure 中建立新的 Windows VM 時遇到問題,請參閱針對 在 Azure 中建立新 Windows 虛擬機器的部署問題進行疑難排解

與我們連絡,以取得說明

如果您有問題或需要相關協助,請建立支援要求,或詢問 Azure community 支援。 您也可以將產品意見反應提交給 Azure 社群支援