嘗試在 Microsoft Dynamics 365 中匯入解決方案修補程式時,發生錯誤碼80048539
本文提供當您嘗試在 Microsoft Dynamics 365 中匯入解決方案修補程式時,可能會發生的錯誤碼80048539解析。
適用於:Microsoft Dynamics 365
原始 KB 編號: 4471087
徵狀
當您嘗試在 Microsoft Dynamics 365 中匯入解決方案修補程式時,您會遇到下列錯誤:
匯入解決方案:[解決方案修補程式名稱] 失敗。
錯誤碼80048539。
如果您下載記錄檔並在 Excel 中開啟,您會看到更多詳細數據,如下所示:
徵兆 1 詳細數據:
失敗0x80048539
解決方案指令清單匯入:FAILURE:修補程式 1.0.1.0 版對父版本 1.1.0.0 無效
徵兆 2 詳細數據:
失敗0x80048539
解決方案指令清單匯入:FAILURE:保留解決方案MyPatchTesting_Upgrade已存在。
原因
注意事項
如果您使用 make.powerapps.com 匯入 Unmanaged 解決方案更新,並收到此錯誤,Microsoft 會察覺到問題並正在進行修正。 若要解決此問題,請開啟 [ 進階 設定],然後選取 [ 不建議更新 () 選項。
錯誤碼 80048539 表示正在匯入無效的修補程式。 有幾個可能的原因,包括下列各項:
原因 1
If you see the error details mentioned in the Symptom 1 Details section mentioned above:
解決方案修補程式版本低於已安裝的解決方案版本。 例如:名為 SolutionA 的解決方案已隨 1.1.0.0 版一起安裝,而您正嘗試匯入 1.0.1.0 版的修補程式。
原因 2
If you see the error details mentioned in the Symptom 2 Details section mentioned above:
如果您已經匯入該解決方案的升級,但尚未套用,就可能發生這種情況。 匯入升級現有解決方案的解決方案之後,解決方案匯入的結尾會提供套用解決方案升級的按鈕。 如果您在先前匯入此解決方案的解決方案升級期間未選取該按鈕,您必須在解決方案清單中找出解決方案,然後選取 [ 套用方案升級 ] 按鈕。
解決方案
解決方案 1
If you see the error details mentioned in the Symptom 1 Details section mentioned above:
確認您嘗試匯入的解決方案修補程式版本比已安裝的解決方案版本更高。
解決方案 2
If you see the error details mentioned in the Symptom 2 Details section mentioned above:
流覽至 [ 設定]、[ 自定義],然後選取 [ 解決方案]。 選取您嘗試升級的現有已安裝解決方案,然後選取 [ 套用解決方案升級]。