癥狀
試想以下情況:
您會將使用者的信箱從內部部署Microsoft Exchange Server 移轉至 Exchange Online。
您會在 停用自動探索 組策略原則設定中停用所有本機自動探索選項。
您停用了允許使用 Office 中連接體驗的政策設定。
在此案例中,當用戶嘗試在 Microsoft Outlook 用戶端上設定Microsoft 365 電子郵件帳戶,或建立新的 Outlook 配置檔時,他們會收到下列其中一則錯誤訊息:
發生錯誤,Outlook 無法設定您的帳戶。 請再試一次。 如果問題持續發生,請連絡您的電子郵件管理員。
很抱歉,我們無法自動設定您的帳戶。
如果使用者在檔案>Office 帳戶連線服務中檢視其 Outlook 帳戶>資訊,他們可能會收到下列錯誤訊息:
Office 目前已離線。
原因
自動探索必須使用本機或雲端選項,在 Outlook 用戶端上設定使用者帳戶,或建立使用者配置檔。
下表列出本機和雲端自動探索選項。
| 本地自動探索選項 | 雲端自動探索選項 |
|---|---|
| 上次已知的有效 URL | Office 365 Autodiscover URL |
| SCP 物件查閱 | 自動探索 V2 服務 |
| 根域查詢 | |
| 自動探索網域查詢 | |
| HTTP 重定向方法 | |
| DNS 中的 SRV 記錄查詢 |
在您的案例中,停用 [ 停用自動探索 組策略] 原則設定中的本機自動探索選項之後,您預期會有雲端自動探索選項可供使用。 不過,由於您也停用了允許在 Office 中使用連線體驗的策略設定,因此無法存取網頁式的雲端自動探索選項。 這種設定組合可有效地停用所有自動探索選項,並防止 Outlook 擷取電子郵件帳戶設定。 它也會產生 徵兆 一節中所述的錯誤訊息。
解決辦法
若要解決此問題,請使用下列其中一種方法。 如果您想要將 Office 中的連線體驗設為停用,請使用第二種方法。
方法 1
在組策略管理編輯器中,啟用下列原則以啟用雲端自動探索選項:
系統管理範本>Microsoft Office 2016>隱私>信任中心>允許在 Office 中使用連線體驗
方法 2
在群組原則管理編輯器中,確保下列原則不會停用本機自動搜尋:
系統管理範本>Microsoft Outlook 2016>帳戶設定>Exchange>停用 AutoDiscover