"An error occurred in the plug-in" when creating a chat widget or social channel

This article provides a resolution for an error that occurs when you try to create a chat widget or social channel in Omnichannel for Customer Service.

Symptoms

Omnichannel solutions are installed in your environment when you receive a new trial organization. However, when you try to create a chat widget, Facebook page, or social channel in the Omnichannel Administration app, one of the error messages similar to the following messages might be displayed:

An error occurred in the PreLiveChatConfigCreatePlugin plug-in.

An error occurred in the PostOperationFacebookCreatePlugin plug-in.

Cause

The solutions for these errors are already installed in your environment, but they must be activated before you can use them.

Resolution

To resolve this issue, follow the steps provided in Provision Omnichannel for Customer Service.