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Firmware updated caused microsoft office to stop working

Catherine Franssens 5 Reputation points
2026-05-20T23:04:52.4933333+00:00

My Dell Pro Max 16 automatically did a firmware update this morning and now when I try to use an MS office product (word, ppt, excel), I get the following error:

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Repair now does nothing. I've gone into apps and done a quick repair and online repair. I have uninstalled and reinstalled MS 365. I have tried to rollback the firmware driver. Nothing has worked to fix the issue. Please help.

Microsoft 365 and Office | Other
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Catherine Franssens 5 Reputation points
2026-05-21T13:33:34.89+00:00

Thanks all for your support. after much troubleshooting, here is the actually root cause and resolution:

Root Cause

The issue was ultimately traced to a corrupted or improperly registered Microsoft Edge WebView2 Runtime installation.

Evidence included:

  • WebView2 installer reported “already installed”
  • WebView2 was missing from Installed Apps
  • msedgewebview2.exe could not be found
  • Office apps dependent on WebView2 crashed immediately on startup

The Dell firmware update likely destabilized or corrupted the WebView2 registration/runtime state used by modern Microsoft 365 applications.


Resolution

Steps That Resolved the Issue

1. Manually removed corrupted WebView2 runtime

Used administrative command line to force-remove the broken installation.

2. Verified removal

Confirmed:


indicating the runtime binaries were removed.

3. Rebooted system

4. Reinstalled Microsoft Edge WebView2 Runtime

Installed the Evergreen Standalone x64 installer.

5. Rebooted again

After reinstalling WebView2, all affected Microsoft Office applications launched and functioned normally.

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  1. Manoel Barros 18,930 Reputation points Independent Advisor
    2026-05-22T01:31:08.5833333+00:00

    Thank you for posting the solution. It will certainly help other users.

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  2. Stefan Blom 341.3K Reputation points MVP Volunteer Moderator
    2026-05-21T07:28:02.8766667+00:00

    Which specific Office product do you have? If it is a subscription, such as Microsoft 365 Personal, try signing out of Office, and then sign back in. Since you are getting an error message, I would suggest that you restart your PC first. If the problem remains, and the Online Repair still fails, you may have to perform a manual uninstall (see https://support.microsoft.com/sv-se/office/avinstallera-office-manuellt-4e2904ea-25c8-4544-99ee-17696bb3027b) and then start fresh.

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  3. Manoel Barros 18,930 Reputation points Independent Advisor
    2026-05-21T01:35:52.3+00:00

    Hi!

    This firmware update may have altered something in the BIOS that could have affected your license. To ensure your computer hasn't been locked, go to https://account.microsoft.com/devices > Check if your computer is listed. To see your computer's name, press Windows + R > Type sysdm.cpl > See Complete Computer Name.

    Also check if your disk is encrypted. If the BIOS was reset during the update, this may have affected BitLocker (if it's enabled). If this happens, your computer would usually be locked by BitLocker... but it's important to check anyway. Press Windows + R > Type control.exe /name Microsoft.BitLockerDriveEncryption > See if any drive has BitLocker enabled.

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