A Teams dialer call from a contact, account, or lead record fails
This article provides a resolution for an issue where a Microsoft Teams dialer call from a contact, account, or lead record fails in Microsoft Dynamics 365 Sales.
Symptoms
A Teams dialer call fails when you make the call by selecting the phone call icon next to a contact, account, or lead number. This issue occurs when the number doesn't have a country code in Dynamics 365 Sales.
Cause
This issue occurs because the country/region code prefixing is enabled.
Resolution
To resolve this issue, disable the country/region code prefixing.
Select the Settings icon on the top toolbar.
Select Personalization Settings.
Clear the Enable country/region code prefixing checkbox.