Can't update records because of missing record access in Salesforce CRM
This article helps you troubleshoot and resolve issues when users can't update CRM records in Microsoft Copilot for Sales because of missing record access in Salesforce CRM.
Note
Microsoft Sales Copilot is rebranded as Microsoft Copilot for Sales in January 2024. The screenshot in this article will be updated with the new name soon.
Who is affected?
Requirement type | Description |
---|---|
Client app | Copilot for Sales Outlook add-in |
Platform | Web and desktop clients |
OS | Windows and Mac |
Deployment | User managed and admin managed |
CRM | Salesforce |
Users | Users trying to update a CRM record from Copilot for Sales |
Symptoms
When a user tries to update a CRM record from the Copilot for Sales add-in for Outlook, the following error message is displayed:
To update Salesforce, ask for edit access for this record.
Cause
The user doesn't have edit access to the record in Salesforce.
When a user tries to edit a record, Copilot for Sales checks if the user has edit access to the object and record in Salesforce. If the user has edit access to the object but not to the record, the error message is displayed.
Resolution
A Salesforce administrator must provide edit access to the record in Salesforce by manually sharing the record with the user.
More information
If your issue is still unresolved, go to the Copilot for Sales - Microsoft Community Hub to engage with our experts.
Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.
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